summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..0973908
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,16 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+from distutils.extension import Extension
+
+py_modules = ['_pysrp', '_ctsrp', 'srp']
+
+ext_modules = [ Extension('_srp', ['_srp.c',], libraries = ['ssl',]), ]
+
+setup(name = 'srp',
+ version = '0.9',
+ description = 'Secure Remote Password Protocol',
+ author = 'Tom Cocagne',
+ author_email = 'tom.cocagne@gmail.com',
+ py_modules = py_modules,
+ ext_modules = ext_modules) \ No newline at end of file