summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTom Cocagne (vubuntu) <devnull@localhost>2010-08-30 23:37:47 -0400
committerTom Cocagne (vubuntu) <devnull@localhost>2010-08-30 23:37:47 -0400
commit39fe54427deddfb11dea6209496b5bcdcaaadd05 (patch)
tree04b44b2f39c60b4585e8a41f59482a02c374bec2 /setup.py
initial commit
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..0973908
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,16 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+from distutils.extension import Extension
+
+py_modules = ['_pysrp', '_ctsrp', 'srp']
+
+ext_modules = [ Extension('_srp', ['_srp.c',], libraries = ['ssl',]), ]
+
+setup(name = 'srp',
+ version = '0.9',
+ description = 'Secure Remote Password Protocol',
+ author = 'Tom Cocagne',
+ author_email = 'tom.cocagne@gmail.com',
+ py_modules = py_modules,
+ ext_modules = ext_modules) \ No newline at end of file