summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore6
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control18
-rw-r--r--debian/copyright59
-rwxr-xr-xdebian/rules20
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch4
-rw-r--r--setup.cfg2
9 files changed, 114 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
index d4e22b0..8e5359b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,8 @@ build
*.pyc
dist/
MANIFEST
-debian/
+debian/python-sqlcipher
+debian/*.log
+debian/files
+debian/*.substvars
+debian/*.debhelper
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..5728206
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pysqlcipher (2.6.3~dev02) unstable; urgency=low
+
+ * Initial debian package
+
+ -- Ben Carrillo <ben@futeisha.org> Thu, 30 May 2013 03:33:25 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..5a8e493
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,18 @@
+Source: pysqlcipher
+Maintainer: Ben Carrillo <ben@futeisha.org>
+Section: python
+Priority: optional
+Build-Depends: python-all-dev (>= 2.6.6-3), libsqlcipher-dev, debhelper (>= 9)
+Standards-Version: 3.9.4
+Uploaders: Micah Anderson <micah@debian.org>
+
+Package: python-sqlcipher
+Architecture: any
+Depends: libsqlcipher0 (>=2.1.1-1), ${misc:Depends}, ${python:Depends}, ${shlibs:Depends}
+Description: DB-API 2.0 interface for SQLCIPHER 3.x
+ Python interface to SQLCipher
+ .
+ pysqlcipher is an interface to the SQLite 3.x embedded relational
+ database engine. It is almost fully compliant with the Python database API
+ version 2.0. At the same time, it also exposes the unique features of
+ SQLCipher.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..b0eabf7
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,59 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: pysqlcipher
+Upstream-Contact: kali@leap.se
+Source: <http://github.com/leapcode/pysqlcipher/>
+
+Files: setup.*
+ Copyright (C) 2013 Kali Kaneko <kali@futeisha.org>
+ Copyright (C) 2005-2010 Gerhard Häring <gh@ghaering.de>
+
+ This software is provided 'as-is', without any express or implied
+ warranty. In no event will the authors be held liable for any
+ damages arising from the use of this software.
+
+ Permission is granted to anyone to use this software for any
+ purpose, including commercial applications, and to alter it and
+ redistribute it freely, subject to the following restrictions:
+
+ 1. The origin of this software must not be misrepresented; you
+ must not claim that you wrote the original software. If you
+ use this software in a product, an acknowledgment in the
+ product documentation would be appreciated but is not
+ required.
+
+ 2. Altered source versions must be plainly marked as such, and
+ must not be misrepresented as being the original software.
+
+ 3. This notice may not be removed or altered from any source
+ distribution.
+
+Files: *
+ Copyright (C) 2005-2010 Gerhard Häring <gh@ghaering.de>
+
+ This software is provided 'as-is', without any express or implied
+ warranty. In no event will the authors be held liable for any
+ damages arising from the use of this software.
+
+ Permission is granted to anyone to use this software for any
+ purpose, including commercial applications, and to alter it and
+ redistribute it freely, subject to the following restrictions:
+
+ 1. The origin of this software must not be misrepresented; you
+ must not claim that you wrote the original software. If you
+ use this software in a product, an acknowledgment in the
+ product documentation would be appreciated but is not
+ required.
+
+ 2. Altered source versions must be plainly marked as such, and
+ must not be misrepresented as being the original software.
+
+ 3. This notice may not be removed or altered from any source
+ distribution.
+
+Files: debian/*
+Copyright: Copyright 2013 Kali Kaneko <kali@futeisha.org>
+License: GPL-3+
+
+License: GPL-3+
+ On Debian systems, the complete text of the GNU General
+ Public License can be found in `/usr/share/common-licenses/GPL'. \ No newline at end of file
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..401e052
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+# Uncomment this to turn on verbose mode.
+#DH_VERBOSE=1
+
+%:
+ dh $@ --with python2 --buildsystem=python_distutils
+
+override_dh_auto_build:
+ python$* setup.py build_sqlcipher
+ python$* setup.py build_py
+
+override_dh_auto_install:
+ python$* setup.py install --skip-build --root=debian/python-sqlcipher \
+ --install-layout=deb
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -rf build
+ rm -rf docs/_build
+ rm -rf *.egg-info
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..7dec5aa
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,4 @@
+version=3
+
+http://pypi.python.org/packages/source/p/pysqlcipher/pysqlcipher-(.*)\.tar\.gz
+
diff --git a/setup.cfg b/setup.cfg
index 1482ef6..9250c50 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[build_ext]
libraries=sqlcipher
+include_dirs=/usr/include/sqlcipher/
#define=
-#include_dirs=/usr/local/include
#library_dirs=/usr/local/lib
#define=SQLITE_OMIT_LOAD_EXTENSION