summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules4
3 files changed, 7 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 385db63..36e6d0c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-pysqlcipher (2.6.3) unstable; urgency=low
+pysqlcipher (2.6.3.1) unstable; urgency=low
* Use libsqlcipher0 2.2.1-2, that uses SQLITE_TEMP_STORE=2. See #726464
diff --git a/debian/control b/debian/control
index b730a4f..a799ca6 100644
--- a/debian/control
+++ b/debian/control
@@ -2,14 +2,14 @@ Source: pysqlcipher
Maintainer: Ben Carrillo <ben@futeisha.org>
Section: python
Priority: optional
-Build-Depends: python-all-dev (>= 2.6.6-3), libsqlcipher-dev, debhelper (>= 9)
+Build-Depends: python-all-dev (>= 2.6.6-3), libsqlcipher-dev (>=2.2.1-2), debhelper (>= 9)
Standards-Version: 3.9.4
Uploaders: Micah Anderson <micah@debian.org>
X-Python-Version: >= 2.5
Package: python-sqlcipher
Architecture: any
-Depends: libsqlcipher0 (>=2.1.1-2), ${misc:Depends}, ${python:Depends}, ${shlibs:Depends}
+Depends: libsqlcipher0 (>=2.2.1-2), ${misc:Depends}, ${python:Depends}, ${shlibs:Depends}
Description: DB-API 2.0 interface for SQLCIPHER 3.x
Python interface to SQLCipher
.
diff --git a/debian/rules b/debian/rules
index 2d9c8f3..2620c92 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,9 @@
# Uncomment this to turn on verbose mode.
#DH_VERBOSE=1
+# Prevent setuptools/distribute from accessing the internet.
+export http_proxy = http://127.0.0.1:9
+
%:
dh $@ --with python2 --buildsystem=python_distutils
@@ -21,3 +24,4 @@ override_dh_auto_clean:
rm -rf build
rm -rf docs/_build
rm -rf *.egg-info
+ find \( -name '._*' -o -name '*.pyc' \) -delete