summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.cfg2
-rw-r--r--setup.py1
2 files changed, 2 insertions, 1 deletions
diff --git a/setup.cfg b/setup.cfg
index 1482ef6..9250c50 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[build_ext]
libraries=sqlcipher
+include_dirs=/usr/include/sqlcipher/
#define=
-#include_dirs=/usr/local/include
#library_dirs=/usr/local/lib
#define=SQLITE_OMIT_LOAD_EXTENSION
diff --git a/setup.py b/setup.py
index f1f93e1..ac1a3cd 100644
--- a/setup.py
+++ b/setup.py
@@ -146,6 +146,7 @@ class LibSQLCipherBuilder(build_ext):
description = ("Build C extension linking against libsqlcipher library.")
def build_extension(self, ext):
+ ext.extra_compile_args.append("-I/usr/include/sqlcipher/")
ext.extra_link_args.append("-lsqlcipher")
build_ext.build_extension(self, ext)