summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorVarac <varac@leap.se>2017-06-22 13:23:20 +0200
committerVarac <varac@leap.se>2017-06-22 14:12:37 +0200
commit13de2b8da99cd74725baefd472694b407a507391 (patch)
tree06836ebba1c8b1650ec3e84c6707a135d18ee351 /debian/rules
parentf472f1a6382abc698f74a1afbb07b2274b3a3d45 (diff)
Add debian folder from debian/platform-0.9 branch
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..2620c92
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+# Uncomment this to turn on verbose mode.
+#DH_VERBOSE=1
+
+# Prevent setuptools/distribute from accessing the internet.
+export http_proxy = http://127.0.0.1:9
+
+%:
+ dh $@ --with python2 --buildsystem=python_distutils
+
+override_dh_auto_build:
+ python$* setup.py build_sqlcipher
+ python$* setup.py build_py
+
+override_dh_auto_install:
+ python$* setup.py install --skip-build --root=debian/python-sqlcipher \
+ --install-layout=deb
+
+override_dh_python2:
+ dh_python2 --no-guessing-versions
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -rf build
+ rm -rf docs/_build
+ rm -rf *.egg-info
+ find \( -name '._*' -o -name '*.pyc' \) -delete