summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2013-05-30 04:57:06 +0900
committerKali Kaneko <kali@leap.se>2013-05-31 03:19:39 +0900
commit4623e6a111193e46a5b86319d3a505f814f024f2 (patch)
treecf9077122bb9cce40e4d7a0f3eb3fec979705aed
parent0ebb159495b941dc40c1f9eaeab250e87edaea7b (diff)
initial debian files
* do not use amalgamation builder * add include dir for libsqlcipher * add libsqlcipher-dev as build-dep
-rw-r--r--.gitignore5
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control17
-rw-r--r--debian/copyright51
-rwxr-xr-xdebian/rules20
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch4
-rw-r--r--setup.cfg2
-rw-r--r--setup.py3
10 files changed, 107 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
index 49be68c..8e5359b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,8 @@ build
*.pyc
dist/
MANIFEST
+debian/python-sqlcipher
+debian/*.log
+debian/files
+debian/*.substvars
+debian/*.debhelper
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..c8a3744
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pysqlcipher (2.6.3~dev02-1) unstable; urgency=low
+
+ * source package automatically created by stdeb 0.6.0+git
+
+ -- Ben Carrillo <ben@futeisha.org> Thu, 30 May 2013 03:33:25 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..ba08497
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,17 @@
+Source: pysqlcipher
+Maintainer: Ben Carrillo <ben@futeisha.org>
+Section: python
+Priority: optional
+Build-Depends: python-all-dev (>= 2.6.6-3), libsqlcipher-dev, debhelper (>= 7)
+Standards-Version: 3.9.1
+
+Package: python-sqlcipher
+Architecture: any
+Depends: libsqlcipher0 (>=2.1.1-1), ${misc:Depends}, ${python:Depends}, ${shlibs:Depends}
+Description: DB-API 2.0 interface for SQLCIPHER 3.x
+ Python interface to SQLCipher
+ .
+ pysqlcipher is an interface to the SQLite 3.x embedded relational
+ database engine. It is almost fully compliant with the Python database API
+ version 2.0. At the same time, it also exposes the unique features of
+ SQLCipher.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..72215e1
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,51 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: pysqlcipher
+Upstream-Contact: kali@leap.se
+Source: <http://github.com/leapcode/pysqlcipher/>
+
+Files: setup.*
+ Copyright (C) 2013 Kali Kaneko <kali@futeisha.org>
+ Copyright (C) 2005-2010 Gerhard Häring <gh@ghaering.de>
+
+ This software is provided 'as-is', without any express or implied
+ warranty. In no event will the authors be held liable for any
+ damages arising from the use of this software.
+
+ Permission is granted to anyone to use this software for any
+ purpose, including commercial applications, and to alter it and
+ redistribute it freely, subject to the following restrictions:
+
+ 1. The origin of this software must not be misrepresented; you
+ must not claim that you wrote the original software. If you
+ use this software in a product, an acknowledgment in the
+ product documentation would be appreciated but is not
+ required.
+
+ 2. Altered source versions must be plainly marked as such, and
+ must not be misrepresented as being the original software.
+
+ 3. This notice may not be removed or altered from any source
+ distribution.
+
+Files: *
+ Copyright (C) 2005-2010 Gerhard Häring <gh@ghaering.de>
+
+ This software is provided 'as-is', without any express or implied
+ warranty. In no event will the authors be held liable for any
+ damages arising from the use of this software.
+
+ Permission is granted to anyone to use this software for any
+ purpose, including commercial applications, and to alter it and
+ redistribute it freely, subject to the following restrictions:
+
+ 1. The origin of this software must not be misrepresented; you
+ must not claim that you wrote the original software. If you
+ use this software in a product, an acknowledgment in the
+ product documentation would be appreciated but is not
+ required.
+
+ 2. Altered source versions must be plainly marked as such, and
+ must not be misrepresented as being the original software.
+
+ 3. This notice may not be removed or altered from any source
+ distribution.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..401e052
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+# Uncomment this to turn on verbose mode.
+#DH_VERBOSE=1
+
+%:
+ dh $@ --with python2 --buildsystem=python_distutils
+
+override_dh_auto_build:
+ python$* setup.py build_sqlcipher
+ python$* setup.py build_py
+
+override_dh_auto_install:
+ python$* setup.py install --skip-build --root=debian/python-sqlcipher \
+ --install-layout=deb
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -rf build
+ rm -rf docs/_build
+ rm -rf *.egg-info
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..7dec5aa
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,4 @@
+version=3
+
+http://pypi.python.org/packages/source/p/pysqlcipher/pysqlcipher-(.*)\.tar\.gz
+
diff --git a/setup.cfg b/setup.cfg
index 1482ef6..9250c50 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[build_ext]
libraries=sqlcipher
+include_dirs=/usr/include/sqlcipher/
#define=
-#include_dirs=/usr/local/include
#library_dirs=/usr/local/lib
#define=SQLITE_OMIT_LOAD_EXTENSION
diff --git a/setup.py b/setup.py
index dff0c64..ac1a3cd 100644
--- a/setup.py
+++ b/setup.py
@@ -48,7 +48,7 @@ sqlite = "sqlite"
PYSQLITE_EXPERIMENTAL = False
#DEV_VERSION = None
-DEV_VERSION = "1"
+DEV_VERSION = "02"
sources = ["src/module.c", "src/connection.c", "src/cursor.c", "src/cache.c",
"src/microprotocols.c", "src/prepare_protocol.c", "src/statement.c",
@@ -146,6 +146,7 @@ class LibSQLCipherBuilder(build_ext):
description = ("Build C extension linking against libsqlcipher library.")
def build_extension(self, ext):
+ ext.extra_compile_args.append("-I/usr/include/sqlcipher/")
ext.extra_link_args.append("-lsqlcipher")
build_ext.build_extension(self, ext)