summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2013-06-05 06:26:49 +0900
committerKali Kaneko <kali@leap.se>2013-06-05 06:26:49 +0900
commitb4043c402c09ec82bb156ecd9d0738887bd33b86 (patch)
tree71d8fc9cde7addd54a442f9d4ce23d870f46777f
parentb42e4e575ae1669f960adada602f2c2c939ed548 (diff)
parent395787d20208c439797855313cc9bbb7fb76784a (diff)
Merge remote-tracking branch 'micah/debian' into debian
Conflicts: debian/control debian/rules setup.py
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules3
-rw-r--r--setup.py3
3 files changed, 6 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 5a8e493..16d3f52 100644
--- a/debian/control
+++ b/debian/control
@@ -5,6 +5,7 @@ Priority: optional
Build-Depends: python-all-dev (>= 2.6.6-3), libsqlcipher-dev, debhelper (>= 9)
Standards-Version: 3.9.4
Uploaders: Micah Anderson <micah@debian.org>
+X-Python-Version: >= 2.5
Package: python-sqlcipher
Architecture: any
diff --git a/debian/rules b/debian/rules
index 401e052..2d9c8f3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,6 +13,9 @@ override_dh_auto_install:
python$* setup.py install --skip-build --root=debian/python-sqlcipher \
--install-layout=deb
+override_dh_python2:
+ dh_python2 --no-guessing-versions
+
override_dh_auto_clean:
dh_auto_clean
rm -rf build
diff --git a/setup.py b/setup.py
index ebf535a..f1aa879 100644
--- a/setup.py
+++ b/setup.py
@@ -22,7 +22,7 @@
# misrepresented as being the original software.
# 3. This notice may not be removed or altered from any source distribution.
-import glob
+#import glob
import os
import re
import sys
@@ -323,6 +323,7 @@ def get_setup_args():
packages=["pysqlcipher", "pysqlcipher.test"] +
(["pysqlcipher.test.py25"], [])[sys.version_info < (2, 5)],
scripts=[],
+
ext_modules=[
Extension(
name="pysqlcipher._sqlite",