summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2013-05-30 12:11:08 -0400
committerKali Kaneko <kali@leap.se>2013-05-31 03:20:12 +0900
commit1601ac461a7f3e0a37544305b86663d2fda44780 (patch)
treeb7e830ba88647f09518556c3306cbc91733c3334
parent4623e6a111193e46a5b86319d3a505f814f024f2 (diff)
several debian/* improvements
* make changelog more suitable than the one generated by stdeb * switch to debhelper version compat 9, this should allow us to get some hardening flags enabled easier * add the debian/* files to the copyright notice * add myself as uploader * fix version so it matches native requirements * update standards revision, no changes * remove installation of unnecessary documentation into wrong location (usr/pysqlcipher-doc/)
-rw-r--r--debian/changelog4
-rw-r--r--debian/compat2
-rw-r--r--debian/control5
-rw-r--r--debian/copyright8
-rw-r--r--setup.py8
5 files changed, 14 insertions, 13 deletions
diff --git a/debian/changelog b/debian/changelog
index c8a3744..5728206 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,5 @@
-pysqlcipher (2.6.3~dev02-1) unstable; urgency=low
+pysqlcipher (2.6.3~dev02) unstable; urgency=low
- * source package automatically created by stdeb 0.6.0+git
+ * Initial debian package
-- Ben Carrillo <ben@futeisha.org> Thu, 30 May 2013 03:33:25 +0900
diff --git a/debian/compat b/debian/compat
index 7f8f011..ec63514 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-7
+9
diff --git a/debian/control b/debian/control
index ba08497..5a8e493 100644
--- a/debian/control
+++ b/debian/control
@@ -2,8 +2,9 @@ Source: pysqlcipher
Maintainer: Ben Carrillo <ben@futeisha.org>
Section: python
Priority: optional
-Build-Depends: python-all-dev (>= 2.6.6-3), libsqlcipher-dev, debhelper (>= 7)
-Standards-Version: 3.9.1
+Build-Depends: python-all-dev (>= 2.6.6-3), libsqlcipher-dev, debhelper (>= 9)
+Standards-Version: 3.9.4
+Uploaders: Micah Anderson <micah@debian.org>
Package: python-sqlcipher
Architecture: any
diff --git a/debian/copyright b/debian/copyright
index 72215e1..b0eabf7 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -49,3 +49,11 @@ Files: *
3. This notice may not be removed or altered from any source
distribution.
+
+Files: debian/*
+Copyright: Copyright 2013 Kali Kaneko <kali@futeisha.org>
+License: GPL-3+
+
+License: GPL-3+
+ On Debian systems, the complete text of the GNU General
+ Public License can be found in `/usr/share/common-licenses/GPL'. \ No newline at end of file
diff --git a/setup.py b/setup.py
index ac1a3cd..49b6667 100644
--- a/setup.py
+++ b/setup.py
@@ -306,13 +306,6 @@ def get_setup_args():
print "Fatal error: PYSQLITE_VERSION could not be detected!"
sys.exit(1)
- data_files = [("pysqlcipher-doc",
- glob.glob("doc/*.html")
- + glob.glob("doc/*.txt")
- + glob.glob("doc/*.css")),
- ("pysqlcipher-doc/code",
- glob.glob("doc/code/*.py"))]
-
#XXX ?
#py_modules = ["sqlcipher"],
@@ -333,7 +326,6 @@ def get_setup_args():
packages=["pysqlcipher", "pysqlcipher.test"] +
(["pysqlcipher.test.py25"], [])[sys.version_info < (2, 5)],
scripts=[],
- data_files=data_files,
ext_modules=[
Extension(