diff options
author | Kali Kaneko <kali@leap.se> | 2014-09-11 21:59:02 -0500 |
---|---|---|
committer | Kali Kaneko <kali@leap.se> | 2014-09-11 21:59:02 -0500 |
commit | 39e388a9f0fd10743c9bb1ab378d15f5c157265e (patch) | |
tree | 1bb23e2e314578e1708f528ae114e9679a20baa8 | |
parent | 61719eade1604530579a64a6ecf4e986f973d3d2 (diff) |
move to setuptools based setup
-rw-r--r-- | setup.py | 11 |
1 files changed, 4 insertions, 7 deletions
@@ -29,13 +29,15 @@ import zipfile from types import ListType, TupleType -from distutils.core import setup, Extension, Command from distutils.command.build import build from distutils.command.build_ext import build_ext from distutils.dep_util import newer_group from distutils.errors import DistutilsSetupError from distutils import log +import setuptools +from setuptools import Extension, Command + import cross_bdist_wininst # If you need to change anything, it should be enough to change setup.cfg. @@ -45,7 +47,6 @@ sqlite = "sqlite" PYSQLITE_EXPERIMENTAL = False DEV_VERSION = None -#DEV_VERSION = "02" PATCH_VERSION = "1" @@ -58,8 +59,6 @@ if PYSQLITE_EXPERIMENTAL: if sys.platform == "darwin": - #from sysconfig import get_config_var - #cf = get_config_var('CFLAGS') # Work around clang raising hard error for unused arguments os.environ['CFLAGS'] = "-Qunused-arguments" print "CFLAGS", os.environ['CFLAGS'] @@ -231,8 +230,6 @@ class MyBuildExt(build_ext): for undef in ext.undef_macros: macros.append((undef,)) - # XXX debug - #objects = [] objects = self.compiler.compile(sources, output_dir=self.build_temp, macros=macros, @@ -367,7 +364,7 @@ def get_setup_args(): def main(): - setup(**get_setup_args()) + setuptools.setup(**get_setup_args()) if __name__ == "__main__": main() |