summaryrefslogtreecommitdiff
path: root/service/setup.py
diff options
context:
space:
mode:
authorBruno Wagner Goncalves <bwagner@thoughtworks.com>2014-08-20 17:17:39 -0300
committerBruno Wagner Goncalves <bwagner@thoughtworks.com>2014-08-20 18:27:01 -0300
commitf06094f9cad86617a31ea2e05accf8d3f63ebb24 (patch)
tree035bb65623040c4ac03a8621c5f5bcd8cf1f4151 /service/setup.py
parent31289cb156540a95dfe51737d9fd4e1a7393f2f2 (diff)
setup.py test, build and develop are now working
Diffstat (limited to 'service/setup.py')
-rw-r--r--service/setup.py20
1 files changed, 12 insertions, 8 deletions
diff --git a/service/setup.py b/service/setup.py
index 2e575d84..5dc26b28 100644
--- a/service/setup.py
+++ b/service/setup.py
@@ -1,5 +1,9 @@
#!/usr/bin/env python
+import sys
+if 'develop' in sys.argv:
+ sys.argv.append('--always-unzip')
+
from setuptools import setup
import os
@@ -14,15 +18,12 @@ setup(name='Pixelated User Agent Service',
author_email='pixelated-team@thoughtworks.com',
url='http://pixelated-project.github.io',
packages=['pixelated'],
+ test_suite='nose.collector',
install_requires=[
- 'scrypt',
- 'Twisted==12.2.0',
- 'flask==0.10.1',
- 'scanner==0.0.5',
- 'requests==2.3.0',
- 'pytest==2.6.0',
- 'mock==1.0.1',
- 'httmock==1.2.2',
+ 'Twisted',
+ 'flask',
+ 'scanner',
+ 'requests',
'srp==1.0.4',
'dirspec==13.10',
'u1db==13.09',
@@ -30,5 +31,8 @@ setup(name='Pixelated User Agent Service',
'leap.soledad.common==0.5.2',
'leap.soledad.client==0.5.2',
'leap.mail==0.3.9-1-gc1f9c92',
+ 'nose',
+ 'mock',
+ 'httmock',
],
)