summaryrefslogtreecommitdiff
path: root/service/setup.py
diff options
context:
space:
mode:
authorBruno Wagner Goncalves <bwagner@thoughtworks.com>2014-08-20 15:43:50 -0300
committerBruno Wagner Goncalves <bwagner@thoughtworks.com>2014-08-20 18:27:01 -0300
commit31289cb156540a95dfe51737d9fd4e1a7393f2f2 (patch)
tree238480ca562c9c65e1aeaaeaebe063549b3718f4 /service/setup.py
parent02df978f9faa4a00b07d2c70d3bd47a25287d0e1 (diff)
Added setup.py and changed app to pixelated because it will be a package
Diffstat (limited to 'service/setup.py')
-rw-r--r--service/setup.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/service/setup.py b/service/setup.py
new file mode 100644
index 00000000..2e575d84
--- /dev/null
+++ b/service/setup.py
@@ -0,0 +1,34 @@
+#!/usr/bin/env python
+
+from setuptools import setup
+import os
+
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+setup(name='Pixelated User Agent Service',
+ version='0.1',
+ description='API to serve the pixelated front-end requests',
+ long_description=read('README.md'),
+ author='Thoughtworks',
+ author_email='pixelated-team@thoughtworks.com',
+ url='http://pixelated-project.github.io',
+ packages=['pixelated'],
+ install_requires=[
+ 'scrypt',
+ 'Twisted==12.2.0',
+ 'flask==0.10.1',
+ 'scanner==0.0.5',
+ 'requests==2.3.0',
+ 'pytest==2.6.0',
+ 'mock==1.0.1',
+ 'httmock==1.2.2',
+ 'srp==1.0.4',
+ 'dirspec==13.10',
+ 'u1db==13.09',
+ 'leap.keymanager==0.3.8',
+ 'leap.soledad.common==0.5.2',
+ 'leap.soledad.client==0.5.2',
+ 'leap.mail==0.3.9-1-gc1f9c92',
+ ],
+ )