summaryrefslogtreecommitdiff
path: root/service/setup.py
diff options
context:
space:
mode:
authorBruno Wagner Goncalves <bwagner@thoughtworks.com>2014-08-20 17:56:43 -0300
committerBruno Wagner Goncalves <bwagner@thoughtworks.com>2014-08-20 18:27:02 -0300
commita443d2d58f46d6b63b7cabe72a8851234a59b10e (patch)
tree271ce5f1fc712741c8330d2ee9df662b385ec5ef /service/setup.py
parentf06094f9cad86617a31ea2e05accf8d3f63ebb24 (diff)
Removed go and runtests - setup.py develop creates a pixelated-user-agent script that you can run
Diffstat (limited to 'service/setup.py')
-rw-r--r--service/setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/service/setup.py b/service/setup.py
index 5dc26b28..91b2a119 100644
--- a/service/setup.py
+++ b/service/setup.py
@@ -17,7 +17,7 @@ setup(name='Pixelated User Agent Service',
author='Thoughtworks',
author_email='pixelated-team@thoughtworks.com',
url='http://pixelated-project.github.io',
- packages=['pixelated'],
+ packages=['pixelated', 'pixelated.adapter', 'pixelated.bitmask_libraries'],
test_suite='nose.collector',
install_requires=[
'Twisted',
@@ -34,5 +34,12 @@ setup(name='Pixelated User Agent Service',
'nose',
'mock',
'httmock',
+ 'service_identity'
],
+ package_data={'': ['config/*']},
+ entry_points={
+ 'console_scripts': [
+ 'pixelated-user-agent = pixelated.user_agent:setup'
+ ]
+ }
)