summaryrefslogtreecommitdiff
path: root/test/javascript/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/javascript/Makefile.am')
-rw-r--r--test/javascript/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/test/javascript/Makefile.am b/test/javascript/Makefile.am
index faaca829..81aec36b 100644
--- a/test/javascript/Makefile.am
+++ b/test/javascript/Makefile.am
@@ -11,5 +11,12 @@
## the License.
EXTRA_DIST = \
- runner.sh \
- test.js
+ cli_runner.js \
+ couch_http.js \
+ run.tpl
+
+run: run.tpl
+ sed -e "s|%abs_top_srcdir%|$(abs_top_srcdir)|" \
+ -e "s|%abs_top_builddir%|$(abs_top_builddir)|" \
+ < $< > $@
+ chmod +x $@