summaryrefslogtreecommitdiff
path: root/test/javascript/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2009-11-26 19:32:08 +0000
committerPaul Joseph Davis <davisp@apache.org>2009-11-26 19:32:08 +0000
commit627b7d2d90c7cfcec2c8bb6e5b5e2b53ea60d217 (patch)
treec8b09655791ba3e5bc8a34344709ded81f8dc73e /test/javascript/Makefile.am
parent95ee619df135a4c8b3ecefe65503c6d1cc7c36da (diff)
Setup JavaScript command line runner.
All JS tests can now be run from the command line using the cURL adapter. In the future I would like to rework this and provide better TAP output. For now, each test is a single TAP assert. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@884675 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'test/javascript/Makefile.am')
-rw-r--r--test/javascript/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/test/javascript/Makefile.am b/test/javascript/Makefile.am
index faaca829..81aec36b 100644
--- a/test/javascript/Makefile.am
+++ b/test/javascript/Makefile.am
@@ -11,5 +11,12 @@
## the License.
EXTRA_DIST = \
- runner.sh \
- test.js
+ cli_runner.js \
+ couch_http.js \
+ run.tpl
+
+run: run.tpl
+ sed -e "s|%abs_top_srcdir%|$(abs_top_srcdir)|" \
+ -e "s|%abs_top_builddir%|$(abs_top_builddir)|" \
+ < $< > $@
+ chmod +x $@