summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Lehnardt <jan@apache.org>2008-10-25 16:41:37 +0000
committerJan Lehnardt <jan@apache.org>2008-10-25 16:41:37 +0000
commit5d222134f9029462d61e2f8b3674a86561641f32 (patch)
tree17fa0d15723cf5b862208818a5cf0ff224efccfa /configure.ac
parente556a8d9cf98de4f65d6eb0b746077e59c180bcd (diff)
Only link against -lcrypt on Linux & BSD systems.
git-svn-id: https://svn.apache.org/repos/asf/incubator/couchdb/trunk@707861 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 020e6c39..2e2a3361 100644
--- a/configure.ac
+++ b/configure.ac
@@ -108,6 +108,12 @@ AC_CHECK_CURL(7.16.0)
AC_SUBST(CURL_CFLAGS)
AC_SUBST(CURL_LIBS)
+case "$(uname -s)" in
+ Linux | *BSD)
+ LIBS="$LIBS -lcrypt"
+ ;;
+esac
+
AC_PATH_PROG([ERL], [erl])
if test x${ERL} = x; then