summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2009-11-26 19:32:08 +0000
committerPaul Joseph Davis <davisp@apache.org>2009-11-26 19:32:08 +0000
commit627b7d2d90c7cfcec2c8bb6e5b5e2b53ea60d217 (patch)
treec8b09655791ba3e5bc8a34344709ded81f8dc73e /Makefile.am
parent95ee619df135a4c8b3ecefe65503c6d1cc7c36da (diff)
Setup JavaScript command line runner.
All JS tests can now be run from the command line using the cURL adapter. In the future I would like to rework this and provide better TAP output. For now, each test is a single TAP assert. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@884675 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ae6ab9fd..fff5648b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,9 +53,11 @@ dev: all
@echo "it creates development ini files as well as a"
@echo "$(top_builddir)/tmp structure for development runtime files."
@echo "Use ./utils/run to launch CouchDB from the source tree."
+ mkdir -p $(top_builddir)/etc/couchdb/default.d
+ mkdir -p $(top_builddir)/etc/couchdb/local.d
mkdir -p $(top_builddir)/tmp/lib
mkdir -p $(top_builddir)/tmp/log
- mkdir -p $(top_builddir)/tmp/run
+ mkdir -p $(top_builddir)/tmp/run/couchdb
distclean-local:
rm -fr $(top_builddir)/tmp