summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2009-05-30 08:02:00 +0000
committerPaul Joseph Davis <davisp@apache.org>2009-05-30 08:02:00 +0000
commit519ba57b75addada246792ba2b93aab13039ba9e (patch)
tree783de260573618c5dd58379389b523970f77b563 /Makefile.am
parentfe63c512d1c012756fc091cd5031be03c6fc498f (diff)
Adding Erlang unit tests.
To run these tests: $ git clone git://github.com/ngerakines/etap.git $ cd etap $ sudo make install $ cd /path/to/couchdb $ ./bootstrap && ./configure && make check So far I've worked through most of couch_file.erl, couch_btree.erl, and couch_doc.erl. Tomorrow I'll be adding coverage reporting so that we can see what code we're actually testing. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@780197 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ce5d04df..d43bbfcc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,6 +36,9 @@ README.gz: $(top_srcdir)/README
THANKS.gz: $(top_srcdir)/THANKS
-gzip -9 < $< > $@
+check: all
+ prove t/*.t
+
dev: all
@echo "This command is intended for developers to use;"
@echo "it creates development ini files as well as a"