summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py25
1 files changed, 0 insertions, 25 deletions
diff --git a/setup.py b/setup.py
index 1a6a7edf..1e77ccf9 100755
--- a/setup.py
+++ b/setup.py
@@ -464,31 +464,6 @@ if IS_LINUX:
extra_options = {}
-if IS_MAC:
- extra_options["app"] = ['src/leap/bitmask/app.py']
- OPTIONS = {
- 'argv_emulation': True,
- 'plist': 'pkg/osx/Info.plist',
- 'iconfile': 'pkg/osx/bitmask.icns',
- }
- extra_options["options"] = {'py2app': OPTIONS}
- extra_options["setup_requires"] = ['py2app']
-
- class jsonschema_recipe(object):
- def check(self, dist, mf):
- m = mf.findNode('jsonschema')
- if m is None:
- return None
-
- # Don't put jsonschema in the site-packages.zip file
- return dict(
- packages=['jsonschema']
- )
-
- import py2app.recipes
- py2app.recipes.jsonschema = jsonschema_recipe()
-
-
setup(
name="leap.bitmask",
package_dir={"": "src"},