summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2015-08-05 19:07:42 -0700
committerIvan Alejandro <ivanalejandro0@gmail.com>2015-08-07 19:02:24 -0300
commit7baaa7689f094c5e82f8b6d2d9bd400a7a102728 (patch)
tree9cce085cf434f3d9c0d116e1bf15e10be5d7df76 /setup.py
parent876fb9c0cf1f9145e478c8ed4bf6dabe7d62b1ff (diff)
[pkg] remove py2app snippet from setup.py
thanks for making our lives easier during all this time, now we're starting a relationship with pyinstaller. maybe our roads cross again in the future.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py25
1 files changed, 0 insertions, 25 deletions
diff --git a/setup.py b/setup.py
index 1a6a7edf..1e77ccf9 100755
--- a/setup.py
+++ b/setup.py
@@ -464,31 +464,6 @@ if IS_LINUX:
extra_options = {}
-if IS_MAC:
- extra_options["app"] = ['src/leap/bitmask/app.py']
- OPTIONS = {
- 'argv_emulation': True,
- 'plist': 'pkg/osx/Info.plist',
- 'iconfile': 'pkg/osx/bitmask.icns',
- }
- extra_options["options"] = {'py2app': OPTIONS}
- extra_options["setup_requires"] = ['py2app']
-
- class jsonschema_recipe(object):
- def check(self, dist, mf):
- m = mf.findNode('jsonschema')
- if m is None:
- return None
-
- # Don't put jsonschema in the site-packages.zip file
- return dict(
- packages=['jsonschema']
- )
-
- import py2app.recipes
- py2app.recipes.jsonschema = jsonschema_recipe()
-
-
setup(
name="leap.bitmask",
package_dir={"": "src"},