summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 1 insertions, 24 deletions
diff --git a/debian/rules b/debian/rules
index 359cdcf..c91550d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,18 +14,6 @@ DDEBUG=`if (echo $(DEB_BUILD_OPTIONS) | grep -q debug) then \
echo ""; \
fi`
-export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
-export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
- confflags += --build $(DEB_HOST_GNU_TYPE) --with-tcl=/usr/lib/tcl8.5
- export CROSS_BUILDING=no
-else
- confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE) --with-tcl=/usr/$(DEB_HOST_GNU_TYPE)/lib/tcl8.5 LDFLAGS=-L/usr/$(DEB_HOST_GNU_TYPE)/lib
- export CROSS_BUILDING=yes
-endif
-
#export DEB_CFLAGS_MAINT_APPEND = -O2 -fno-strict-aliasing
export CFLAGS += -O2 -fno-strict-aliasing \
@@ -47,9 +35,9 @@ configure-stamp:
./configure --prefix=/usr --mandir="/usr/share/man" \
$(confflags) --enable-threadsafe \
--enable-load-extension \
+ --disable-tcl \
--libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
--libexecdir=\$${libdir}/sqlite3 \
- TCLLIBDIR=/usr/lib/tcltk/sqlite3 \
$(DDEBUG)
touch $@
@@ -79,21 +67,10 @@ install: build
$(MAKE) install DESTDIR=$(DESTDIR)
chrpath -d $(DESTDIR)/usr/bin/sqlite3
- chrpath -d $(DESTDIR)/usr/lib/tcltk/sqlite3/libtclsqlite3.so
- install -m 0664 libtclsqlite3.la $(DESTDIR)/usr/lib/tcltk/sqlite3/
# Remove *.la files per policy 3.9.1.0
sed -i "/dependency_libs/ s/'.*'/''/" `find $(DESTDIR) -name '*.la'`
- # Create the pkgIndex.tcl file for the Tcl module. This generated file
- # actually turns out to be relocatable.
- echo "pkg_mkIndex -verbose $(DESTDIR)/usr/lib/tcltk/sqlite3" | \
- LD_LIBRARY_PATH=$(DESTDIR)/usr/lib/$(DEB_HOST_MULTIARCH) \
- tclsh8.5
- grep -q 'package ifneeded sqlite3' \
- $(DESTDIR)/usr/lib/tcltk/sqlite3/pkgIndex.tcl || \
- (echo "pkgIndex.tcl seems to be wrong" && exit 1)
-
binary-indep: build install
dh_testdir
dh_testroot