summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/02-lemon-snprintf.patch83
-rw-r--r--debian/patches/30-cross.patch51
-rw-r--r--debian/patches/series2
3 files changed, 0 insertions, 136 deletions
diff --git a/debian/patches/02-lemon-snprintf.patch b/debian/patches/02-lemon-snprintf.patch
deleted file mode 100644
index 67c8600..0000000
--- a/debian/patches/02-lemon-snprintf.patch
+++ /dev/null
@@ -1,83 +0,0 @@
---- sqlite3-3.6.10.orig/tool/lemon.c 2010-03-13 17:12:20.004507610 +0000
-+++ sqlite3-3.6.10/tool/lemon.c 2010-03-13 17:25:51.799607483 +0000
-@@ -2347,7 +2347,7 @@
- for(z=psp->filename, nBack=0; *z; z++){
- if( *z=='\\' ) nBack++;
- }
-- sprintf(zLine, "#line %d ", psp->tokenlineno);
-+ snprintf(zLine,sizeof zLine, "#line %d ", psp->tokenlineno);
- nLine = lemonStrlen(zLine);
- n += nLine + lemonStrlen(psp->filename) + nBack;
- }
-@@ -2916,7 +2916,7 @@
- while( cfp ){
- char buf[20];
- if( cfp->dot==cfp->rp->nrhs ){
-- sprintf(buf,"(%d)",cfp->rp->index);
-+ snprintf(buf,sizeof buf,"(%d)",cfp->rp->index);
- fprintf(fp," %5s ",buf);
- }else{
- fprintf(fp," ");
-@@ -2970,6 +2970,7 @@
- char *pathbufptr;
- char *pathbuf;
- char *path,*cp;
-+ size_t pathsz;
- char c;
-
- #ifdef __WIN32__
-@@ -3087,14 +3121,16 @@
-
- cp = strrchr(lemp->filename,'.');
- if( cp ){
-- sprintf(buf,"%.*s.lt",(int)(cp-lemp->filename),lemp->filename);
-+ snprintf(buf,sizeof buf,"%.*s.lt",(int)(cp-lemp->filename),lemp->filename);
- }else{
-- sprintf(buf,"%s.lt",lemp->filename);
-+ snprintf(buf,sizeof buf,"%s.lt",lemp->filename);
- }
- if( access(buf,004)==0 ){
- tpltname = buf;
- }else if( access(templatename,004)==0 ){
- tpltname = templatename;
-+ }else if( access("/usr/share/lemon/lempar.c",004)==0 ){
-+ tpltname = "/usr/share/lemon/lempar.c";
- }else{
- tpltname = pathsearch(lemp->argv0,templatename,0);
- }
-@@ -3106,7 +3109,7 @@
- }
- in = fopen(tpltname,"rb");
- if( in==0 ){
-- fprintf(stderr,"Can't open the template file \"%s\".\n",templatename);
-+ fprintf(stderr,"Can't open the template file \"%s\".\n",tpltname);
- lemp->errorcnt++;
- return 0;
- }
-@@ -3240,7 +3243,7 @@
- while( n-- > 0 ){
- c = *(zText++);
- if( c=='%' && n>0 && zText[0]=='d' ){
-- sprintf(zInt, "%d", p1);
-+ snprintf(zInt,sizeof zInt, "%d", p1);
- p1 = p2;
- strcpy(&z[used], zInt);
- used += lemonStrlen(&z[used]);
-@@ -3856,7 +3859,7 @@
- /* Generate a table containing the symbolic name of every symbol
- */
- for(i=0; i<lemp->nsymbol; i++){
-- sprintf(line,"\"%s\",",lemp->symbols[i]->name);
-+ snprintf(line,sizeof line,"\"%s\",",lemp->symbols[i]->name);
- fprintf(out," %-15s",line);
- if( (i&3)==3 ){ fprintf(out,"\n"); lineno++; }
- }
-@@ -4022,7 +4023,7 @@
- in = file_open(lemp,".h","rb");
- if( in ){
- for(i=1; i<lemp->nterminal && fgets(line,LINESIZE,in); i++){
-- sprintf(pattern,"#define %s%-30s %2d\n",prefix,lemp->symbols[i]->name,i);
-+ snprintf(pattern,sizeof pattern,"#define %s%-30s %2d\n",prefix,lemp->symbols[i]->name,i);
- if( strcmp(line,pattern) ) break;
- }
- fclose(in);
diff --git a/debian/patches/30-cross.patch b/debian/patches/30-cross.patch
deleted file mode 100644
index a698a6e..0000000
--- a/debian/patches/30-cross.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-Index: sqlite3-3.7.4/Makefile.in
-===================================================================
---- sqlite3-3.7.4.orig/Makefile.in
-+++ sqlite3-3.7.4/Makefile.in
-@@ -534,10 +534,20 @@
-
- # Rules to build the LEMON compiler generator
- #
--lemon$(BEXE): $(TOP)/tool/lemon.c $(TOP)/src/lempar.c
-+lemon-for-build$(BEXE): $(TOP)/tool/lemon.c $(TOP)/src/lempar.c
- $(BCC) -o $@ $(TOP)/tool/lemon.c
- cp $(TOP)/src/lempar.c .
-
-+lemon$(TEXE): $(TOP)/tool/lemon.c $(TOP)/src/lempar.c
-+ $(LTLINK) -o $@ $(TOP)/tool/lemon.c
-+ cp $(TOP)/src/lempar.c .
-+
-+ifeq ($(CROSS_BUILDING),yes)
-+LEMON_FOR_BUILD = lemon-for-build$(BEXE)
-+else
-+LEMON_FOR_BUILD = lemon$(TEXE)
-+endif
-+
- # Rules to build individual *.o files from generated *.c files. This
- # applies to:
- #
-@@ -790,10 +800,10 @@
- #
- parse.h: parse.c
-
--parse.c: $(TOP)/src/parse.y lemon$(BEXE) $(TOP)/addopcodes.awk
-+parse.c: $(TOP)/src/parse.y $(LEMON_FOR_BUILD) $(TOP)/addopcodes.awk
- cp $(TOP)/src/parse.y .
- rm -f parse.h
-- ./lemon$(BEXE) $(OPT_FEATURE_FLAGS) $(OPTS) parse.y
-+ ./$(LEMON_FOR_BUILD) $(OPT_FEATURE_FLAGS) $(OPTS) parse.y
- mv parse.h parse.h.temp
- $(NAWK) -f $(TOP)/addopcodes.awk parse.h.temp >parse.h
-
-@@ -930,7 +940,10 @@
- rm -f *.lo *.la *.o sqlite3$(TEXE) libsqlite3.la
- rm -f sqlite3.h opcodes.*
- rm -rf .libs .deps
-- rm -f lemon$(BEXE) lempar.c parse.* sqlite*.tar.gz
-+ rm -f $(LEMON_FOR_BUILD) lempar.c parse.* sqlite*.tar.gz
-+ifeq ($(CROSS_BUILDING), yes)
-+ rm -f lemon$(TEXE)
-+endif
- rm -f mkkeywordhash$(BEXE) keywordhash.h
- rm -f $(PUBLISH)
- rm -f *.da *.bb *.bbg gmon.out
diff --git a/debian/patches/series b/debian/patches/series
index 9dc7e3f..36ff741 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,6 +1,4 @@
-02-lemon-snprintf.patch
10-520466-libsqlite3-depends-on-libdl.patch
10-520478-squash-bad-deps.patch
11-update-manpage.patch
20-hurd-locking-style.patch
-30-cross.patch