summaryrefslogtreecommitdiff
path: root/debian/patches/20-change-name-to-sqlcipher.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/20-change-name-to-sqlcipher.patch')
-rw-r--r--debian/patches/20-change-name-to-sqlcipher.patch43
1 files changed, 37 insertions, 6 deletions
diff --git a/debian/patches/20-change-name-to-sqlcipher.patch b/debian/patches/20-change-name-to-sqlcipher.patch
index 4d02dda..64b10c9 100644
--- a/debian/patches/20-change-name-to-sqlcipher.patch
+++ b/debian/patches/20-change-name-to-sqlcipher.patch
@@ -1,7 +1,38 @@
---- a/VERSION
-+++ b/VERSION
-@@ -1 +1 @@
--3.8.6
-\ No newline at end of file
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -89,6 +89,7 @@ TCC += $(OPTS)
+ VERSION = @VERSION@
+ VERSION_NUMBER = @VERSION_NUMBER@
+ RELEASE = @RELEASE@
++SQLCIPHER_VERSION = @SQLCIPHER_VERSION@
+
+ # Filename extensions
+ #
+--- /dev/null
++++ b/VERSION_SQLCIPHER
+@@ -0,0 +1 @@
+3.2.0
-\ No newline at end of file
+--- a/configure.ac
++++ b/configure.ac
+@@ -179,6 +179,10 @@ VERSION_NUMBER=[`cat $srcdir/VERSION \
+ AC_MSG_NOTICE(Version number set to $VERSION_NUMBER)
+ AC_SUBST(VERSION_NUMBER)
+
++SQLCIPHER_VERSION=[`cat $srcdir/VERSION_SQLCIPHER | sed 's/^\([0-9]*\.*[0-9]*\).*/\1/'`]
++AC_MSG_NOTICE(SQLCipher Version set to $SQLCIPHER_VERSION)
++AC_SUBST(SQLCIPHER_VERSION)
++
+ #########
+ # Check to see if the --with-hints=FILE option is used. If there is none,
+ # then check for a files named "$host.hints" and ../$hosts.hints where
+--- a/sqlcipher.pc.in
++++ b/sqlcipher.pc.in
+@@ -7,7 +7,7 @@ includedir=@includedir@
+
+ Name: SQLCipher
+ Description: SQL database engine
+-Version: @PACKAGE_VERSION@
++Version: @SQLCIPHER_VERSION@
+ Libs: -L${libdir} -lsqlcipher
+ Libs.private: @LIBS@
+ Cflags: -I${includedir}