summaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control56
1 files changed, 56 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 6c7ad6c..9a01096 100644
--- a/debian/control
+++ b/debian/control
@@ -21,6 +21,20 @@ Description: Command line interface for SQLCipher
database access without running a separate RDBMS process. It allows one to
have per-database or page-by-page encryption using AES-256 from OpenSSL.
.
+ SQLCipher has a small footprint and great performance so it’s ideal for
+ protecting embedded application databases and is well suited for mobile
+ development.
+ .
+ * as little as 5-15% overhead for encryption
+ * 100% of data in the database file is encrypted
+ * Uses good security practices (CBC mode, key derivation)
+ * Zero-configuration and application level cryptography
+ * Algorithms provided by the peer reviewed OpenSSL crypto library.
+ .
+ SQLCipher has broad platform support for with C/C++, Obj-C, QT, Win32/.NET,
+ Java, Python, Ruby, Linux, Mac OS X, iPhone/iOS, Android, Xamarin.iOS, and
+ Xamarin.Android.
+ .
SQLCipher v2.1.1 is based on SQLite3 v3.7.14.1.
Package: libsqlcipher0-dbg
@@ -35,6 +49,20 @@ Description: SQLCipher debugging symbols
database access without running a separate RDBMS process. It allows one to
have per-database or page-by-page encryption using AES-256 from OpenSSL.
.
+ SQLCipher has a small footprint and great performance so it’s ideal for
+ protecting embedded application databases and is well suited for mobile
+ development.
+ .
+ * as little as 5-15% overhead for encryption
+ * 100% of data in the database file is encrypted
+ * Uses good security practices (CBC mode, key derivation)
+ * Zero-configuration and application level cryptography
+ * Algorithms provided by the peer reviewed OpenSSL crypto library.
+ .
+ SQLCipher has broad platform support for with C/C++, Obj-C, QT,
+ Win32/.NET/Mono, Java, Python, Ruby, Linux, Mac OS X, iPhone/iOS, Android,
+ Xamarin.iOS, and Xamarin.Android.
+ .
SQLCipher v2.1.1 is based on SQLite3 v3.7.14.1.
.
This package contains the debugging symbols for the libraries.
@@ -52,6 +80,20 @@ Description: SQLCipher shared library
database access without running a separate RDBMS process. It allows one to
have per-database or page-by-page encryption using AES-256 from OpenSSL.
.
+ SQLCipher has a small footprint and great performance so it’s ideal for
+ protecting embedded application databases and is well suited for mobile
+ development.
+ .
+ * as little as 5-15% overhead for encryption
+ * 100% of data in the database file is encrypted
+ * Uses good security practices (CBC mode, key derivation)
+ * Zero-configuration and application level cryptography
+ * Algorithms provided by the peer reviewed OpenSSL crypto library.
+ .
+ SQLCipher has broad platform support for with C/C++, Obj-C, QT,
+ Win32/.NET/Mono, Java, Python, Ruby, Linux, Mac OS X, iPhone/iOS, Android,
+ Xamarin.iOS, and Xamarin.Android.
+ .
SQLCipher v2.1.1 is based on SQLite3 v3.7.14.1.
Package: libsqlcipher-dev
@@ -65,6 +107,20 @@ Description: SQLCipher development files
database access without running a separate RDBMS process. It allows one to
have per-database or page-by-page encryption using AES-256 from OpenSSL.
.
+ SQLCipher has a small footprint and great performance so it’s ideal for
+ protecting embedded application databases and is well suited for mobile
+ development.
+ .
+ * as little as 5-15% overhead for encryption
+ * 100% of data in the database file is encrypted
+ * Uses good security practices (CBC mode, key derivation)
+ * Zero-configuration and application level cryptography
+ * Algorithms provided by the peer reviewed OpenSSL crypto library.
+ .
+ SQLCipher has broad platform support for with C/C++, Obj-C, QT,
+ Win32/.NET/Mono, Java, Python, Ruby, Linux, Mac OS X, iPhone/iOS, Android,
+ Xamarin.iOS, and Xamarin.Android.
+ .
This package contains the development files (headers, static libraries)
.
SQLCipher v2.1.1 is based on SQLite3 v3.7.14.1.