summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <hans@eds.org>2012-09-25 21:24:35 -0400
committerHans-Christoph Steiner <hans@eds.org>2012-09-27 15:24:21 -0400
commit1d0102794ca90b4520129336794da06e4e79b0d1 (patch)
tree7e40d7d2232ee6a03a36e891e508a875fe3b77a4 /debian/rules
parent16f07f9eca01294dc1a4dd62f4b13856ddbdf262 (diff)
get lintian overrides working, and generalize rule to all archs
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 2 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c088965..b3d7ac2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -77,6 +77,7 @@ binary-indep: build install
dh_testdir
dh_testroot
+ dh_lintian -i
dh_install -i --sourcedir=$(DESTDIR)
dh_installdocs -i
dh_installchangelogs -i
@@ -95,6 +96,7 @@ binary-arch: build install
sed -e"s,\$${DEB_HOST_MULTIARCH},${DEB_HOST_MULTIARCH},g" \
debian/$${file}.in > debian/$$file; \
done
+ dh_lintian -a
dh_install -a --sourcedir=$(DESTDIR)
dh_installman -a
dh_installdocs -a