summaryrefslogtreecommitdiff
path: root/debian/patches/10-520478-squash-bad-deps.patch
diff options
context:
space:
mode:
authorHans-Christoph Steiner <hans@eds.org>2012-03-30 20:43:01 -0400
committerHans-Christoph Steiner <hans@eds.org>2012-03-30 20:43:01 -0400
commit246cfeb8b989732222389be34a7fe11091533f09 (patch)
treef0a250f78670d012325b3ca522f086485188cc24 /debian/patches/10-520478-squash-bad-deps.patch
parent7bb481fda9ecb134804b49c2ce77ca28f7eea583 (diff)
checking in packaging from sqlite3_3.7.11-2.debian.tar.gz
Diffstat (limited to 'debian/patches/10-520478-squash-bad-deps.patch')
-rw-r--r--debian/patches/10-520478-squash-bad-deps.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/patches/10-520478-squash-bad-deps.patch b/debian/patches/10-520478-squash-bad-deps.patch
new file mode 100644
index 0000000..71f6362
--- /dev/null
+++ b/debian/patches/10-520478-squash-bad-deps.patch
@@ -0,0 +1,25 @@
+--- sqlite3-3.6.11.orig/Makefile.in 2009-03-24 11:40:55.000000000 -0700
++++ sqlite3-3.6.11/Makefile.in 2009-03-24 11:42:36.000000000 -0700
+@@ -487,18 +487,20 @@
+ libsqlite3.la: $(LIBOBJ)
+ $(LTLINK) -o $@ $(LIBOBJ) $(TLIBS) \
+ ${ALLOWRELEASE} -rpath "$(libdir)" -version-info "8:6:8"
++ sed -i "/dependency_libs/s/'.*'/''/" $@
+
+ libtclsqlite3.la: tclsqlite.lo libsqlite3.la
+ $(LTLINK) -o $@ tclsqlite.lo \
+- libsqlite3.la @TCL_STUB_LIB_SPEC@ $(TLIBS) \
++ libsqlite3.la @TCL_STUB_LIB_SPEC@ \
+ -rpath "$(TCLLIBDIR)" \
+ -version-info "8:6:8" \
+ -avoid-version
++ sed -i "/dependency_libs/s/'.*'/''/" $@
+
+ sqlite3$(TEXE): $(TOP)/src/shell.c libsqlite3.la sqlite3.h
+ $(LTLINK) $(READLINE_FLAGS) \
+ -o $@ $(TOP)/src/shell.c libsqlite3.la \
+- $(LIBREADLINE) $(TLIBS) -rpath "$(libdir)"
++ $(LIBREADLINE) -rpath "$(libdir)"
+
+ # This target creates a directory named "tsrc" and fills it with
+ # copies of all of the C source code and header files needed to