summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b1c0b9db..b016f124 100644
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,6 @@ from setuptools import (
install_requirements = [
'configparser',
'couchdb',
- 'leap.common',
'pysqlcipher',
'simplejson',
'twisted>=12.0.0', # TODO: maybe we just want twisted-web?
@@ -45,6 +44,7 @@ tests_requirements = [
'mock',
'nose2',
'testscenarios',
+ 'leap.common',
]
@@ -89,4 +89,7 @@ setup(
tests_require=tests_requirements,
data_files=data_files,
classifiers=trove_classifiers,
+ extras_require={
+ 'signaling': ['leap.common'],
+ }
)