summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 7 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 3f99cbce..916dc832 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,7 @@
"""
Setup file for leap.soledad
"""
+import os
import re
import sys
import versioneer
@@ -83,10 +84,12 @@ client = [
]
# needed until kali merges the py3 fork back into the main pysqlcipher repo
-if sys.version_info.major >= 3:
- client += ['pysqlcipher3']
-else:
- client += ['pysqlcipher']
+readthedocs = bool(os.environ.get('READTHEDOCS'))
+if not readthedocs:
+ if sys.version_info.major >= 3:
+ client += ['pysqlcipher3']
+ else:
+ client += ['pysqlcipher']
server = [
'configparser',