summaryrefslogtreecommitdiff
path: root/testing/setup.py
diff options
context:
space:
mode:
authordrebs <drebs@leap.se>2016-09-24 11:32:13 -0300
committerdrebs <drebs@leap.se>2016-09-30 09:08:03 -0300
commitd5bbe37495ee733be5f78de72364f3ec48ed7a0d (patch)
treea23ed57a323bd9e8db088700970d0f6f53e1da91 /testing/setup.py
parentb1a7b538ab851c9e1aab3be5ba31411d658a4773 (diff)
[test] use pytest tmpdir fixture in all tests
Tests that were imported from u1db or created on top of that structure were leaving temporary directories behind. This could cause problems in test servers, either by filling the partition or by extrapolating the maximum amount of files in a directory. This commit replaces all usages of temporary directories in the old test structure by pytest tmpdir fixture, which properly cares for removing temporary directories.
Diffstat (limited to 'testing/setup.py')
-rw-r--r--testing/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/testing/setup.py b/testing/setup.py
index 059b2489..c1204c9a 100644
--- a/testing/setup.py
+++ b/testing/setup.py
@@ -5,5 +5,5 @@ from setuptools import find_packages
setup(
name='test_soledad',
packages=find_packages('.'),
- package_data={'': ['*.conf']}
+ package_data={'': ['*.conf', 'u1db_tests/testing-certs/*']}
)