summaryrefslogtreecommitdiff
path: root/soledad/setup.py
diff options
context:
space:
mode:
authorTomas Touceda <chiiph@leap.se>2013-06-21 11:58:43 -0300
committerTomas Touceda <chiiph@leap.se>2013-06-21 11:58:43 -0300
commitd4ea5ac0e78aff6a9224073b4096aa9ad52d4382 (patch)
tree6d803596fe08450a678e39210eb6c2fc9a6db9a0 /soledad/setup.py
parent194ff4c40047462e112737a74968ec21a75bfba7 (diff)
parenteb4d19190cd4b726613a04bae534c2f1b89c7183 (diff)
Merge remote-tracking branch 'drebs/feature/2616-separate-soledad-into-client-and-server-2' into develop
Diffstat (limited to 'soledad/setup.py')
-rw-r--r--soledad/setup.py84
1 files changed, 84 insertions, 0 deletions
diff --git a/soledad/setup.py b/soledad/setup.py
new file mode 100644
index 00000000..f0d070da
--- /dev/null
+++ b/soledad/setup.py
@@ -0,0 +1,84 @@
+# -*- coding: utf-8 -*-
+# setup.py
+# Copyright (C) 2013 LEAP
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+
+from setuptools import (
+ setup,
+ find_packages
+)
+
+
+install_requirements = [
+ 'pysqlcipher',
+ 'pysqlite', # TODO: this should not be a dep, see #2945
+ 'simplejson',
+ 'oauth', # this is not strictly needed by us, but we need it
+ # until u1db adds it to its release as a dep.
+ 'u1db',
+ 'six==1.1.0',
+ 'scrypt',
+ 'pyxdg',
+ 'pycrypto',
+ 'pyOpenSSL',
+]
+
+
+tests_requirements = [
+ 'mock',
+ 'nose2',
+ 'testscenarios',
+ 'leap.common',
+ 'leap.soledad_server',
+]
+
+
+trove_classifiers = (
+ "Development Status :: 3 - Alpha",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: "
+ "GNU General Public License v3 or later (GPLv3+)",
+ "Environment :: Console",
+ "Operating System :: OS Independent",
+ "Operating System :: POSIX",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Topic :: Database :: Front-Ends",
+ "Topic :: Software Development :: Libraries :: Python Modules"
+)
+
+setup(
+ name='leap.soledad',
+ version='0.1.1',
+ url='https://leap.se/',
+ license='GPLv3+',
+ description='Synchronization of locally encrypted data among devices.',
+ author='The LEAP Encryption Access Project',
+ author_email='info@leap.se',
+ long_description=(
+ "Soledad is the part of LEAP that allows application data to be "
+ "securely shared among devices. It provides, to other parts of the "
+ "LEAP client, an API for data storage and sync."
+ ),
+ namespace_packages=["leap"],
+ packages=find_packages('src', exclude=['leap.soledad.tests']),
+ package_dir={'': 'src'},
+ test_suite='leap.soledad.tests',
+ install_requires=install_requirements,
+ tests_require=tests_requirements,
+ classifiers=trove_classifiers,
+ extras_require={'signaling': ['leap.common']},
+)