summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authordrebs <drebs@leap.se>2013-03-07 17:23:26 -0300
committerdrebs <drebs@leap.se>2013-03-07 17:23:26 -0300
commita6939bbd6b48608547da4ca23c5c8cc2fa73b550 (patch)
tree7efde183c470f7692eaf9c02f7f6247652025b37 /setup.py
parentd89c1849d551de68d26a1f56798ee5084dca6556 (diff)
Add setup.py file.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..e79e0901
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+from distutils.core import setup
+
+setup(
+ name='leap.soledad',
+ # TODO: change version according to decisions regarding soledad versus
+ # leap client versions.
+ version='0.0.1-dev',
+ url='https://leap.se/',
+ license='GPLv3+',
+ description='Synchronization of locally encrypted data among devices.',
+ author='The LEAP Encryption Access Project',
+ author_email='info@leap.se',
+ long_description=(
+ "Soledad is the part of LEAP that allows application data to be "
+ "securely shared among devices. It provides, to other parts of the "
+ "LEAP client, an API for data storage and sync."
+ ),
+ packages=['leap', 'leap.soledad', 'leap.soledad.backends'],
+ package_dir = {'': 'src'},
+ test_suite='leap.soledad.tests',
+)
+