summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authordrebs <drebs@riseup.net>2017-11-08 09:19:35 -0200
committerdrebs <drebs@riseup.net>2017-11-09 18:35:51 -0200
commit50ba592fc01d702f91b4662212a6fa5865267614 (patch)
tree495ae430fcabc52c0c48c54426a35e3bbc2ff5e4 /debian
parentf7bdd435a3910ca2f5ad88020f52d42484db7ef7 (diff)
[pkg] add man page for user db creation script
Closes: #8895
Diffstat (limited to 'debian')
-rw-r--r--debian/control8
-rw-r--r--debian/manpages1
-rwxr-xr-xdebian/rules5
3 files changed, 13 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 38322a88..7f48acb8 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,13 @@ Section: python
Priority: optional
Maintainer: Micah Anderson <micah@debian.org>
Uploaders: LEAP automated build <sysdev@leap.se>
-Build-Depends: python-setuptools (>= 0.6b3), python-all (>= 2.6.6-3), python-wheel, debhelper (>= 9), dh-python, dh-systemd
+Build-Depends: python-setuptools (>= 0.6b3)
+ , python-all (>= 2.6.6-3)
+ , python-wheel
+ , debhelper (>= 9)
+ , dh-python
+ , dh-systemd
+ , python-docutils
Standards-Version: 4.1.1
Package: soledad-server
diff --git a/debian/manpages b/debian/manpages
new file mode 100644
index 00000000..42fb695f
--- /dev/null
+++ b/debian/manpages
@@ -0,0 +1 @@
+docs/man/soledad-create-userdb.1
diff --git a/debian/rules b/debian/rules
index 36bb6748..e78a8c31 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,6 +13,10 @@ NAME=soledad-server
%:
dh $@ --with python2 --namespace=leap.soledad --buildsystem=pybuild --with=systemd
+override_dh_prep:
+ rst2man docs/man/soledad-create-userdb.1.rst docs/man/soledad-create-userdb.1
+ dh_prep
+
override_dh_installinit:
dh_systemd_enable -p${NAME} --name=${NAME} ${NAME}.service
dh_installinit -p${NAME} --no-start --noscripts
@@ -21,3 +25,4 @@ override_dh_auto_clean:
dh_auto_clean
find . -name "*.pyc" -exec rm -rf {} \;
find . -name ".tox" -exec rm -rf {} \;
+ rm -f docs/man/soledad-create-userdb.1