summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2016-05-18 12:28:37 -0400
committerKali Kaneko <kali@leap.se>2016-05-18 12:28:37 -0400
commit09568a70ef68a4ef121d9e79fdc5366c4297544e (patch)
treeb8d4358f8bf9c65876961676a603f4d42b59cdb7
parent0673e3e3f70ebd3e0716c48966c5b3b75ed4f952 (diff)
parent4ca544212c3f5af08fdbad06133b0b443f6dfa02 (diff)
Merge branch 'debian/experimental' into debian/platform-0.8debian/platform-0.8
-rw-r--r--client/pkg/requirements.pip4
-rw-r--r--client/setup.py28
-rw-r--r--client/src/leap/soledad/client/_version.py17
-rw-r--r--common/setup.py29
-rw-r--r--common/src/leap/soledad/common/_version.py17
-rw-r--r--debian/changelog11
-rw-r--r--debian/control6
-rw-r--r--server/pkg/requirements.pip10
-rw-r--r--server/setup.py28
-rw-r--r--server/src/leap/soledad/server/_version.py17
10 files changed, 101 insertions, 66 deletions
diff --git a/client/pkg/requirements.pip b/client/pkg/requirements.pip
index 5519d2f6..ec7d7699 100644
--- a/client/pkg/requirements.pip
+++ b/client/pkg/requirements.pip
@@ -1,6 +1,8 @@
#pysqlcipher>2.6.3
u1db
scrypt
-cchardet
+# cchardet not packaged, we need python-chardet from the
+# repos instead.
+chardet
zope.proxy
oauth
diff --git a/client/setup.py b/client/setup.py
index 4480e247..90986dde 100644
--- a/client/setup.py
+++ b/client/setup.py
@@ -68,14 +68,20 @@ class freeze_debianver(Command):
# unpacked source archive. Distribution tarballs contain a pre-generated copy
# of this file.
-version_version = '{version}'
-full_revisionid = '{full_revisionid}'
-"""
- templatefun = r"""
-
-def get_versions(default={}, verbose=False):
- return {'version': version_version,
- 'full-revisionid': full_revisionid}
+import json
+import sys
+
+version_json = '''
+{
+ "dirty": false,
+ "error": null,
+ "full-revisionid": "FULL_REVISIONID",
+ "version": "VERSION_STRING"
+}
+''' # END VERSION_JSON
+
+def get_versions():
+ return json.loads(version_json)
"""
def initialize_options(self):
@@ -90,9 +96,9 @@ def get_versions(default={}, verbose=False):
if proceed != "y":
print("He. You scared. Aborting.")
return
- subst_template = self.template.format(
- version=VERSION_SHORT,
- full_revisionid=VERSION_REVISION) + self.templatefun
+ subst_template = self.template.replace(
+ 'VERSION_STRING', VERSION_SHORT).replace(
+ 'FULL_REVISIONID', VERSION_REVISION)
versioneer_cfg = versioneer.get_config_from_root('.')
with open(versioneer_cfg.versionfile_source, 'w') as f:
f.write(subst_template)
diff --git a/client/src/leap/soledad/client/_version.py b/client/src/leap/soledad/client/_version.py
index a72d4aa7..ebc8925f 100644
--- a/client/src/leap/soledad/client/_version.py
+++ b/client/src/leap/soledad/client/_version.py
@@ -5,10 +5,17 @@
# unpacked source archive. Distribution tarballs contain a pre-generated copy
# of this file.
-version_version = '0.8.0'
-full_revisionid = '259d37b430564c03f27d0835e23769473034df6f'
+import json
+import sys
+version_json = '''
+{
+ "dirty": false,
+ "error": null,
+ "full-revisionid": "91cbf6c084569a24c4186f3ff745448d3c51756a",
+ "version": "0.8.0"
+}
+''' # END VERSION_JSON
-def get_versions(default={}, verbose=False):
- return {'version': version_version,
- 'full-revisionid': full_revisionid}
+def get_versions():
+ return json.loads(version_json)
diff --git a/common/setup.py b/common/setup.py
index 8d9c4d6e..c1f4d5ac 100644
--- a/common/setup.py
+++ b/common/setup.py
@@ -75,14 +75,20 @@ class freeze_debianver(Command):
# unpacked source archive. Distribution tarballs contain a pre-generated copy
# of this file.
-version_version = '{version}'
-full_revisionid = '{full_revisionid}'
-"""
- templatefun = r"""
-
-def get_versions(default={}, verbose=False):
- return {'version': version_version,
- 'full-revisionid': full_revisionid}
+import json
+import sys
+
+version_json = '''
+{
+ "dirty": false,
+ "error": null,
+ "full-revisionid": "FULL_REVISIONID",
+ "version": "VERSION_STRING"
+}
+''' # END VERSION_JSON
+
+def get_versions():
+ return json.loads(version_json)
"""
def initialize_options(self):
@@ -97,14 +103,13 @@ def get_versions(default={}, verbose=False):
if proceed != "y":
print("He. You scared. Aborting.")
return
- subst_template = self.template.format(
- version=VERSION_SHORT,
- full_revisionid=VERSION_REVISION) + self.templatefun
+ subst_template = self.template.replace(
+ 'VERSION_STRING', VERSION_SHORT).replace(
+ 'FULL_REVISIONID', VERSION_REVISION)
versioneer_cfg = versioneer.get_config_from_root('.')
with open(versioneer_cfg.versionfile_source, 'w') as f:
f.write(subst_template)
-
cmdclass = versioneer.get_cmdclass()
#
diff --git a/common/src/leap/soledad/common/_version.py b/common/src/leap/soledad/common/_version.py
index a72d4aa7..ebc8925f 100644
--- a/common/src/leap/soledad/common/_version.py
+++ b/common/src/leap/soledad/common/_version.py
@@ -5,10 +5,17 @@
# unpacked source archive. Distribution tarballs contain a pre-generated copy
# of this file.
-version_version = '0.8.0'
-full_revisionid = '259d37b430564c03f27d0835e23769473034df6f'
+import json
+import sys
+version_json = '''
+{
+ "dirty": false,
+ "error": null,
+ "full-revisionid": "91cbf6c084569a24c4186f3ff745448d3c51756a",
+ "version": "0.8.0"
+}
+''' # END VERSION_JSON
-def get_versions(default={}, verbose=False):
- return {'version': version_version,
- 'full-revisionid': full_revisionid}
+def get_versions():
+ return json.loads(version_json)
diff --git a/debian/changelog b/debian/changelog
index 99d1b94f..a164bda0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,15 +1,14 @@
soledad (0.8.0) unstable; urgency=medium
- * Release of soledad 0.8.0
+ * Update to 0.8.0 release
- -- Ben Carrillo <ben@futeisha.org> Wed, 04 May 2016 11:36:35 -0400
+ -- Ben Carrillo <ben@futeisha.org> Mon, 25 Apr 2016 21:08:20 -0400
-soledad (0.8.0~alpha+3) unstable; urgency=medium
+soledad (0.7.4) unstable; urgency=medium
- * Pre-release of soledad 0.8.0
- * Cherry-pick commits to create soledad user, add it to sudoers.
+ * Update to 0.7.4 release
- -- Ben Carrillo <ben@futeisha.org> Tue, 29 Sep 2015 10:43:00 -0400
+ -- Ben Carrillo <ben@futeisha.org> Thu, 29 Oct 2015 12:11:02 -0400
soledad (0.7.3) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 88d2d36e..6de62bc6 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Package: soledad-server
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}, python-configparser, python-couchdb,
python-simplejson, python-oauth, python-u1db, python-routes, python-openssl,
- soledad-common (>= 0.5.0), python-six, python-twisted-web (>= 13.0.0-1~bpo70+1),
+ soledad-common (>= 0.8.0), python-six, python-twisted-web (>= 13.0.0-1~bpo70+1),
sudo
Description: Synchronization of locally encrypted data among devices (server files)
Soledad is the part of LEAP that allows application data to be securely
@@ -34,8 +34,8 @@ Package: soledad-client
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}, python-sqlcipher (>= 2.6.3.3+b1),
python-simplejson, python-oauth, python-u1db, python-scrypt,
- python-dirspec, python-pycryptopp (>= 0.6.0.20120313-1~), soledad-common,
- python-chardet, python-twisted-core (>= 13.0.0)
+ python-dirspec, soledad-common, python-chardet,
+ python-twisted-core (>= 13.0.0)
Description: Synchronization of locally encrypted data among devices (client files)
Soledad is the part of LEAP that allows application data to be securely
shared among devices. It provides, to other parts of the LEAP client, an
diff --git a/server/pkg/requirements.pip b/server/pkg/requirements.pip
index e7d474f9..d6430872 100644
--- a/server/pkg/requirements.pip
+++ b/server/pkg/requirements.pip
@@ -2,12 +2,8 @@ configparser
u1db
routes
PyOpenSSL
-#twisted # we don't want all twisted deps in deb!
-#pinned for wheezy compatibility
-Beaker==1.6.3 #wheezy
-couchdb==0.8 #wheezy
-# XXX -- fix me!
-# oauth is not strictly needed by us, but we need it until u1db adds it to its
-# release as a dep.
+Beaker
+couchdb
+
oauth
diff --git a/server/setup.py b/server/setup.py
index 8a7fbe45..b3b26010 100644
--- a/server/setup.py
+++ b/server/setup.py
@@ -77,14 +77,20 @@ class freeze_debianver(Command):
# unpacked source archive. Distribution tarballs contain a pre-generated copy
# of this file.
-version_version = '{version}'
-full_revisionid = '{full_revisionid}'
-"""
- templatefun = r"""
-
-def get_versions(default={}, verbose=False):
- return {'version': version_version,
- 'full-revisionid': full_revisionid}
+import json
+import sys
+
+version_json = '''
+{
+ "dirty": false,
+ "error": null,
+ "full-revisionid": "FULL_REVISIONID",
+ "version": "VERSION_STRING"
+}
+''' # END VERSION_JSON
+
+def get_versions():
+ return json.loads(version_json)
"""
def initialize_options(self):
@@ -99,9 +105,9 @@ def get_versions(default={}, verbose=False):
if proceed != "y":
print("He. You scared. Aborting.")
return
- subst_template = self.template.format(
- version=VERSION_SHORT,
- full_revisionid=VERSION_REVISION) + self.templatefun
+ subst_template = self.template.replace(
+ 'VERSION_STRING', VERSION_SHORT).replace(
+ 'FULL_REVISIONID', VERSION_REVISION)
versioneer_cfg = versioneer.get_config_from_root('.')
with open(versioneer_cfg.versionfile_source, 'w') as f:
f.write(subst_template)
diff --git a/server/src/leap/soledad/server/_version.py b/server/src/leap/soledad/server/_version.py
index a72d4aa7..ebc8925f 100644
--- a/server/src/leap/soledad/server/_version.py
+++ b/server/src/leap/soledad/server/_version.py
@@ -5,10 +5,17 @@
# unpacked source archive. Distribution tarballs contain a pre-generated copy
# of this file.
-version_version = '0.8.0'
-full_revisionid = '259d37b430564c03f27d0835e23769473034df6f'
+import json
+import sys
+version_json = '''
+{
+ "dirty": false,
+ "error": null,
+ "full-revisionid": "91cbf6c084569a24c4186f3ff745448d3c51756a",
+ "version": "0.8.0"
+}
+''' # END VERSION_JSON
-def get_versions(default={}, verbose=False):
- return {'version': version_version,
- 'full-revisionid': full_revisionid}
+def get_versions():
+ return json.loads(version_json)