summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordrebs <drebs@leap.se>2016-09-09 09:30:25 -0300
committerdrebs <drebs@leap.se>2016-09-09 10:16:04 -0300
commitb51196e2d28fde4dd28daad680b541bb206cae2b (patch)
tree2aa6e80d530eeefb1e22280a6bc66c1f7800b4a7
parent6b23b3f3215f2443aa3e790559b63a41b3040072 (diff)
[pkg] add debian directory for 0.8.1debian/experimental-0.9
-rw-r--r--debian/.gitignore8
-rw-r--r--debian/__init__.py6
-rw-r--r--debian/changelog216
-rw-r--r--debian/clean1
-rw-r--r--debian/compat1
-rw-r--r--debian/control45
-rw-r--r--debian/copyright16
-rw-r--r--debian/pydist-overrides11
-rwxr-xr-xdebian/rules30
l---------debian/soledad-server.init1
-rw-r--r--debian/soledad-server.install2
-rw-r--r--debian/soledad-sudoers2
-rw-r--r--debian/source/format1
13 files changed, 340 insertions, 0 deletions
diff --git a/debian/.gitignore b/debian/.gitignore
new file mode 100644
index 00000000..f10ef354
--- /dev/null
+++ b/debian/.gitignore
@@ -0,0 +1,8 @@
+files
+*.postinst.debhelper
+*.prerm.debhelper
+*.postrm.debhelper
+*.substvars
+soledad-client/
+soledad-common/
+soledad-server/
diff --git a/debian/__init__.py b/debian/__init__.py
new file mode 100644
index 00000000..f48ad105
--- /dev/null
+++ b/debian/__init__.py
@@ -0,0 +1,6 @@
+# See http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages
+try:
+ __import__('pkg_resources').declare_namespace(__name__)
+except ImportError:
+ from pkgutil import extend_path
+ __path__ = extend_path(__path__, __name__)
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 00000000..bfcfab1c
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,216 @@
+soledad (0.8.1+nmu1) unstable; urgency=medium
+
+ * Update do 0.8.1 release (NMU).
+
+ -- Andre Bianchi <drebs@riseup.net> Fri, 09 Sep 2016 09:26:51 -0300
+
+soledad (0.8.0) unstable; urgency=medium
+
+ * Update to 0.8.0 release
+
+ -- Ben Carrillo <ben@futeisha.org> Mon, 25 Apr 2016 21:08:20 -0400
+
+soledad (0.7.4) unstable; urgency=medium
+
+ * Update to 0.7.4 release
+
+ -- Ben Carrillo <ben@futeisha.org> Thu, 29 Oct 2015 12:11:02 -0400
+
+soledad (0.7.3) unstable; urgency=medium
+
+ * Update to 0.7.3 release
+
+ -- Ben Carrillo <ben@futeisha.org> Thu, 24 Sep 2015 15:23:44 -0400
+
+soledad (0.7.2) unstable; urgency=medium
+
+ * Update to 0.7.2 release
+ * Update short descriptions in debian/control to be unique
+ * Update debian/copyright to point to the specific GPL-3 symlink
+ * Fix init.d-script-does-not-provide-itself lintian error
+
+ -- Micah Anderson <micah@debian.org> Tue, 01 Sep 2015 15:43:11 -0400
+
+soledad (0.6.5.1) unstable; urgency=medium
+
+ * Update to 0.6.5 release
+ * Cherry-pick 67f17cd30 to fix illegal header error (closes #7122)
+
+ -- Ben Carrillo <ben@futeisha.org> Wed, 10 Jun 2015 12:06:56 -0400
+
+soledad (0.6.3) unstable; urgency=medium
+
+ * Update to 0.6.3 release
+ * Fix server initscript location (#6557)
+
+ -- db <db@leap.se> Tue, 16 Dec 2014 11:26:58 -0400
+
+soledad (0.6.0) unstable; urgency=low
+
+ [ Ben Carrillo ]
+ * Disable WAL (workaround for #5562)
+ * Use python-chardet
+
+ [ db ]
+ * Update to 0.6.0 release.
+ * Do not depend on pysqlite (closes #2945)
+
+ -- db <db@leap.se> Wed, 01 Oct 2014 15:39:38 -0300
+
+soledad (0.5.2.1) unstable; urgency=medium
+
+ * Update soledad-client version dependency on python-pycryptopp
+ to make backports to wheezy easier
+
+ -- Micah Anderson <micah@debian.org> Tue, 01 Jul 2014 14:37:45 -0400
+
+soledad (0.5.2) unstable; urgency=low
+
+ * Update to 0.5.2 release.
+
+ -- db <db@leap.se> Fri, 06 Jun 2014 16:53:03 -0300
+
+soledad (0.5.1) unstable; urgency=low
+
+ * Update to 0.5.1 release.
+
+ -- db <db@leap.se> Fri, 06 Jun 2014 16:48:57 -0300
+
+soledad (0.5.0) unstable; urgency=low
+
+ * Update to 0.5.0 release.
+
+ -- Ben Carrillo <ben@futeisha.org> Wed, 09 Apr 2014 15:47:11 -0500
+
+soledad (0.4.4.1) unstable; urgency=medium
+
+ * Set version dependency of python-pycryptopp for soledad-client
+
+ -- Micah Anderson <micah@debian.org> Tue, 10 Dec 2013 21:10:27 -0500
+
+soledad (0.4.4) unstable; urgency=low
+
+ * Update to 0.4.4 release.
+
+ -- Ben Carrillo <ben@futeisha.org> Tue, 10 Dec 2013 17:06:28 -0400
+
+soledad (0.4.3) unstable; urgency=low
+
+ * Update to 0.4.3 release
+
+ -- Ben Carrillo <ben@futeisha.org> Fri, 15 Nov 2013 23:37:55 -0200
+
+soledad (0.4.2.2) unstable; urgency=low
+
+ * soledad-client: Cherry-pick change for autocommit mode, which fixes
+ a "cannot start a transaction within a transaction" that was
+ rendering the client unusable.
+ * soledad-client: Cherry-pick for default encoding, which fixes a bug
+ that was rendering the client unusable.
+
+ -- Ben Carrillo <ben@futeisha.org> Thu, 07 Nov 2013 20:09:29 -0200
+
+soledad (0.4.2.1) unstable; urgency=low
+
+ * Change cchardet dependency for chardet explicitly.
+
+ -- Ben Carrillo <ben@futeisha.org> Wed, 06 Nov 2013 17:46:03 -0200
+
+soledad (0.4.2) unstable; urgency=low
+
+ * Update to 0.4.2
+
+ -- Ben Carrillo <ben@futeisha.org> Tue, 05 Nov 2013 11:18:39 -0200
+
+soledad (0.4.1) unstable; urgency=low
+
+ * Update to 0.4.1.
+ * Freeze version to 0.4.1 using freeze_debianver command.
+ * Use python-chardet as a fallback.
+
+ -- Micah Anderson <micah@debian.org> Tue, 15 Oct 2013 15:27:19 -0300
+
+soledad (0.4.0) unstable; urgency=low
+
+ * Update to 0.4.0.
+
+ -- Micah Anderson <micah@debian.org> Tue, 24 Sep 2013 16:50:19 -0400
+
+soledad (0.3.2) unstable; urgency=low
+
+ * Update to 0.3.2
+
+ -- Micah Anderson <micah@debian.org> Thu, 12 Sep 2013 14:13:56 +0200
+
+soledad (0.3.1.1) unstable; urgency=low
+
+ [ Ben Carrillo ]
+ * Fix installation of __init__ file on namespace module.
+ * Add LICENSE.
+
+ [ Micah Anderson ]
+ * Add fix to initscript so it uses the new namespace
+
+ -- Micah Anderson <micah@debian.org> Thu, 29 Aug 2013 14:46:23 -0400
+
+soledad (0.3.1) unstable; urgency=low
+
+ [ Ben Carrillo ]
+ * Update to latest release.
+ * Fix pydist-overrides.
+
+ [ Micah Anderson ]
+ * Stop setup.py from installing initscript so packaging can
+
+ -- Micah Anderson <micah@debian.org> Mon, 26 Aug 2013 18:21:09 +0200
+
+soledad (0.3.1~pre) unstable; urgency=low
+
+ * Upgrade to latest code in develop
+ * Setup additional binary package
+ * Fix pydist-overrides for new package name
+
+ -- Micah Anderson <micah@debian.org> Thu, 22 Aug 2013 14:57:54 -0400
+
+soledad (0.3.0.3) unstable; urgency=low
+
+ * Fixed missing epoch on python-twisted-conch
+
+ -- Micah Anderson <micah@debian.org> Thu, 15 Aug 2013 13:16:54 -0400
+
+soledad (0.3.0.2) unstable; urgency=low
+
+ * Pin twisted version in Depends to get 13 or greater
+
+ -- Micah Anderson <micah@debian.org> Thu, 15 Aug 2013 11:31:57 -0400
+
+soledad (0.3.0.1) unstable; urgency=low
+
+ * Update initscript to require that START=yes is set
+ in /etc/default/soledad
+
+ -- Micah Anderson <micah@debian.org> Wed, 14 Aug 2013 11:18:01 -0400
+
+soledad (0.3.0) unstable; urgency=low
+
+ * Update to 0.3.0
+
+ -- Micah Anderson <micah@debian.org> Tue, 13 Aug 2013 14:42:06 -0400
+
+soledad (0.2.3) unstable; urgency=low
+
+ * Upgrade to new release
+
+ -- Micah Anderson <micah@debian.org> Mon, 29 Jul 2013 20:47:19 -0400
+
+soledad (0.2.2.1) unstable; urgency=low
+
+ * Fix installation of initscript
+
+ -- Micah Anderson <micah@debian.org> Thu, 18 Jul 2013 15:54:51 -0400
+
+soledad (0.2.2) unstable; urgency=low
+
+ * Initial debian package
+
+ -- Micah Anderson <micah@debian.org> Thu, 30 May 2013 15:11:11 -0400
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 00000000..c9349d36
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+src/leap.soledad.egg-info/*
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 00000000..ec635144
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..2d261e16
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,45 @@
+Source: soledad
+Section: python
+Priority: optional
+Maintainer: Micah Anderson <micah@debian.org>
+Build-Depends: python-setuptools (>= 0.6b3), python-all (>= 2.6.6-3), debhelper (>= 9),
+ dh-python
+Standards-Version: 3.9.6
+
+Package: soledad-server
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}, python-configparser, python-couchdb,
+ python-simplejson, python-oauth, python-u1db, python-routes, python-openssl,
+ soledad-common (>= 0.8.0), python-six, python-twisted-web (>= 13.0.0-1~bpo70+1),
+ sudo
+Description: Synchronization of locally encrypted data among devices (server files)
+ Soledad is the part of LEAP that allows application data to be securely
+ shared among devices. It provides, to other parts of the LEAP client, an
+ API for data storage and sync.
+ .
+ This package contains the server components.
+
+Package: soledad-common
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}, python-simplejson, python-oauth, python-u1db,
+ python-six
+Description: Synchronization of locally encrypted data among devices (common files)
+ Soledad is the part of LEAP that allows application data to be securely
+ shared among devices. It provides, to other parts of the LEAP client, an
+ API for data storage and sync.
+ .
+ This package contains the common soledad libraries. For the server, see the
+ soledad-server package
+
+Package: soledad-client
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}, python-sqlcipher (>= 2.6.3.3+b1),
+ python-simplejson, python-oauth, python-u1db, python-scrypt,
+ python-dirspec, soledad-common, python-chardet,
+ python-twisted-core (>= 13.0.0)
+Description: Synchronization of locally encrypted data among devices (client files)
+ Soledad is the part of LEAP that allows application data to be securely
+ shared among devices. It provides, to other parts of the LEAP client, an
+ API for data storage and sync.
+ .
+ This package contains the soledad client.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 00000000..edd67753
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,16 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: soledad
+Upstream-Contact: info@leap.se
+Source: <git://code.leap.se/soledad/>
+
+Files: *
+Copyright: Copyright (C) 2013 LEAP
+License: GPL-3+
+
+Files: debian/*
+Copyright: Copyright 2013 Micah Anderson <micah@leap.se>
+License: GPL-3+
+
+License: GPL-3+
+ On Debian systems, the complete text of the GNU General
+ Public License can be found in `/usr/share/common-licenses/GPL-3'.
diff --git a/debian/pydist-overrides b/debian/pydist-overrides
new file mode 100644
index 00000000..a577bca6
--- /dev/null
+++ b/debian/pydist-overrides
@@ -0,0 +1,11 @@
+pysqlcipher python-sqlcipher
+PyOpenSSL python-openssl
+u1db python-u1db
+scrypt python-scrypt
+cchardet python-chardet
+zope.proxy python-zope.proxy
+configparser python-configparser
+leap.soledad.common soledad-common
+leap.soledad.server soledad-server
+leap.soledad.client soledad-client
+leap.common python-leap-common
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..1ffc91e7
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,30 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#DH_VERBOSE=1
+
+%:
+ dh $@ --with python2 --namespace=leap.soledad
+
+override_dh_auto_clean:
+ cd client && python setup.py clean -a
+ cd common && python setup.py clean -a
+ cd server && python setup.py clean -a
+
+override_dh_auto_install:
+ cd client && python setup.py install --root=../debian/soledad-client
+ cd common && python setup.py install --root=../debian/soledad-common
+ cd server && LEAP_SKIP_INIT=1 python setup.py install --root=../debian/soledad-server
+
+override_dh_install:
+ # leap.soledad provides the leap.soledad namespace __init__.py
+ for pv in $(shell pyversions -vr debian/control); do \
+ cp common/src/leap/__init__.py debian/soledad-common/usr/local/lib/python$$pv/*-packages/leap/; \
+ cp common/src/leap/__init__.py debian/soledad-common/usr/local/lib/python$$pv/*-packages/leap/soledad/; \
+ done
+ dh_install
+
+override_dh_auto_clean:
+ dh_auto_clean
+ find . -name "*.pyc" -exec rm -rf {} \;
+ find . -name ".tox" -exec rm -rf {} \;
diff --git a/debian/soledad-server.init b/debian/soledad-server.init
new file mode 120000
index 00000000..6448df05
--- /dev/null
+++ b/debian/soledad-server.init
@@ -0,0 +1 @@
+../server/pkg/soledad-server \ No newline at end of file
diff --git a/debian/soledad-server.install b/debian/soledad-server.install
new file mode 100644
index 00000000..01342c4b
--- /dev/null
+++ b/debian/soledad-server.install
@@ -0,0 +1,2 @@
+server/pkg/create-user-db usr/bin/
+debian/soledad-sudoers etc/sudoers.d/
diff --git a/debian/soledad-sudoers b/debian/soledad-sudoers
new file mode 100644
index 00000000..642497f8
--- /dev/null
+++ b/debian/soledad-sudoers
@@ -0,0 +1,2 @@
+Cmnd_Alias SOLEDAD_CREATE_DB = /usr/bin/create-user-db
+soledad ALL=(soledad-admin) NOPASSWD: SOLEDAD_CREATE_DB
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 00000000..89ae9db8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)