summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKali Kaneko (leap communications) <kali@leap.se>2019-01-16 00:23:46 +0100
committerKali Kaneko (leap communications) <kali@leap.se>2019-01-16 19:46:16 +0100
commitf6267d0fd0d1f8eb5a7f822a418d82d5def62eae (patch)
tree0c87841616d2d8fe1be9d1347691815d50b1426b /debian/rules
parent7053932af89d8848fb37eca6362c21deb2172af4 (diff)
[pkg] initial debianization
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..193f2a9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# This has to be exported to make some magic below work.
+export DH_OPTIONS
+
+export DH_GOPKG = 0xacab.org/leap/riseup_vpn
+export DH_GOLANG_EXCLUDES = vendor
+
+%:
+ dh $@ --with golang --buildsystem golang
+
+override_dh_auto_test:
+
+override_dh_auto_build:
+ # FIXME how ugly is this?
+ # this is the only way I found of having a quilt package made for the customized builds that gets
+ # in place the sources for bitmask-vpn
+ # XXX What var can I use instead of the hardcoded build dir?
+ ln -s `pwd` obj-x86_64-linux-gnu/src/0xacab.org/leap/bitmask-systray
+ dh_auto_build
+
+override_dh_install:
+ mkdir -p $(CURDIR)/debian/riseup-vpn/usr/sbin
+ cp $(CURDIR)/helpers/bitmask-root $(CURDIR)/debian/riseup-vpn/usr/sbin/
+ mkdir -p $(CURDIR)/debian/riseup-vpn/usr/share/polkit-1/actions
+ cp $(CURDIR)/helpers/se.leap.bitmask.policy $(CURDIR)/debian/riseup-vpn/usr/share/polkit-1/actions
+ rm -fr $(CURDIR)/debian/riseup-vpn/usr/share/gocode
+ rm -fr $(CURDIR)/debian/riseup-vpn/usr/bin/transifex
+ strip $(CURDIR)/debian/riseup-vpn/usr/bin/riseup_vpn
+ dh_install