summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKali Kaneko (leap communications) <kali@leap.se>2019-01-24 00:52:41 +0100
committerKali Kaneko (leap communications) <kali@leap.se>2019-01-24 02:05:42 +0100
commit6d0164d023718031357fd53f3aec5c9d1d764bcd (patch)
treebf0b1d4e1b7914b20db3dd7e77ef5f12ced609df /debian/rules
parent2231cce159bcf92004fbcc23a20399b26bc49243 (diff)
[pkg] update deb after code refactor
this must be run from the Makefile. it also needs recent changes to bitmask-vpn, including the removal of golang.org/x/text and others from the vendor.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 8 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 193f2a9..7bfad39 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,7 +4,7 @@
# This has to be exported to make some magic below work.
export DH_OPTIONS
-export DH_GOPKG = 0xacab.org/leap/riseup_vpn
+export DH_GOPKG = 0xacab.org/leap/bitmask-vpn
export DH_GOLANG_EXCLUDES = vendor
%:
@@ -13,11 +13,9 @@ export DH_GOLANG_EXCLUDES = vendor
override_dh_auto_test:
override_dh_auto_build:
- # FIXME how ugly is this?
- # this is the only way I found of having a quilt package made for the customized builds that gets
- # in place the sources for bitmask-vpn
- # XXX What var can I use instead of the hardcoded build dir?
- ln -s `pwd` obj-x86_64-linux-gnu/src/0xacab.org/leap/bitmask-systray
+ rm -rf src/0xacab.org/leap/bitmask-vpn/tools/transifex
+ rm -rf obj-x86_64-linux-gnu/src/0xacab.org/leap/bitmask-vpn/tools/transifex
+ rm -rf tools
dh_auto_build
override_dh_install:
@@ -26,6 +24,8 @@ override_dh_install:
mkdir -p $(CURDIR)/debian/riseup-vpn/usr/share/polkit-1/actions
cp $(CURDIR)/helpers/se.leap.bitmask.policy $(CURDIR)/debian/riseup-vpn/usr/share/polkit-1/actions
rm -fr $(CURDIR)/debian/riseup-vpn/usr/share/gocode
- rm -fr $(CURDIR)/debian/riseup-vpn/usr/bin/transifex
- strip $(CURDIR)/debian/riseup-vpn/usr/bin/riseup_vpn
+ strip $(CURDIR)/debian/riseup-vpn/usr/bin/bitmask-vpn
+ rm $(CURDIR)/debian/riseup-vpn/usr/bin/bitmask-helper
+ rm $(CURDIR)/debian/riseup-vpn/usr/bin/bitmask-connect
+ mv $(CURDIR)/debian/riseup-vpn/usr/bin/bitmask-vpn $(CURDIR)/debian/riseup-vpn/usr/bin/riseup-vpn
dh_install