summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..bc6abae
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,16 @@
+from setuptools import setup, find_packages
+
+import taskthread
+
+
+setup(
+ name='taskthread',
+ version=taskthread.__version__,
+ url='http://hpcloud.com',
+ license='Apache',
+ author='John Herndon',
+ author_email='john.herndon@hp.com',
+ description='Simple thread module to repetitively perform a task on a single thread',
+ long_description=open('README.rst').read(),
+ packages=find_packages()
+)