summaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control24
1 files changed, 22 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 53996fd..f389dfa 100644
--- a/debian/control
+++ b/debian/control
@@ -2,15 +2,22 @@ Source: srp
Maintainer: Ben Carrillo <ben@futeisha.org>
Section: python
Priority: optional
-Build-Depends: python-all-dev (>= 2.6.6-3), debhelper (>= 9)
+Build-Depends:
+ python-all-dev (>= 2.6.6-3),
+ debhelper (>= 9),
+ python-sphinx (>= 1.0.7+dfsg),
Standards-Version: 3.9.4
+X-Python-Version: >= 2.6
Vcs-Hg: https://code.google.com/p/pysrp/
Vcs-Browser: http://code.google.com/p/pysrp/source/browse/
Homepage: http://code.google.com/p/pysrp/
Package: python-srp
Architecture: any
-Depends: ${misc:Depends}, ${python:Depends}, ${shlibs:Depends}
+Depends:
+ ${misc:Depends},
+ ${python:Depends},
+ ${shlibs:Depends}
Description: Secure Remote Password protocol implementation
This package provides an implementation of the Secure Remote Password
protocol (SRP). SRP is a cryptographically strong authentication
@@ -33,3 +40,16 @@ Description: Secure Remote Password protocol implementation
the authenticated connection. However, successful authentication does
result in a cryptographically strong shared key that can be used
for symmetric-key encryption.
+
+Package: python-srp-doc
+Architecture: all
+Section: doc
+Depends: ${misc:Depends}, ${sphinxdoc:Depends}
+Suggests: python-doc
+Description: Secure Remote Password protocol implementation
+ This package provides an implementation of the Secure Remote Password
+ protocol (SRP). SRP is a cryptographically strong authentication
+ protocol for password-based, mutual authentication over an insecure
+ network connection.
+ .
+ This package provides detailed documentation on python-srp usage.