summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTom Cocagne <devnull@localhost>2011-03-30 23:10:32 -0400
committerTom Cocagne <devnull@localhost>2011-03-30 23:10:32 -0400
commiteddf3e82d22944c022e4e48d214f08c95ddae5a9 (patch)
tree97901b9a687f5f0cb00d555b12c314ca0cb6098f /setup.py
parentd8850eb95f58144ba6904d64792249711fff77f3 (diff)
prepping for 1.0 release
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py14
1 files changed, 12 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 0973908..dc32ff2 100755
--- a/setup.py
+++ b/setup.py
@@ -8,9 +8,19 @@ py_modules = ['_pysrp', '_ctsrp', 'srp']
ext_modules = [ Extension('_srp', ['_srp.c',], libraries = ['ssl',]), ]
setup(name = 'srp',
- version = '0.9',
+ version = '1.0',
description = 'Secure Remote Password Protocol',
author = 'Tom Cocagne',
author_email = 'tom.cocagne@gmail.com',
+ url = 'http://code.google.com/p/pysrp/',
py_modules = py_modules,
- ext_modules = ext_modules) \ No newline at end of file
+ ext_modules = ext_modules,
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: C',
+ 'Topic :: Security',
+ ],)