summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..39c25db
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,36 @@
+from __future__ import print_function
+import os
+import sys
+import sh
+
+try: from distutils.core import setup
+except ImportError: from setuptools import setup
+
+
+setup(
+ name="sh",
+ version=sh.__version__,
+ description="Python subprocess interface",
+ author="Andrew Moffat",
+ author_email="andrew.robert.moffat@gmail.com",
+ url="https://github.com/amoffat/sh",
+ license="MIT",
+ py_modules=["sh"],
+ classifiers=[
+ "Development Status :: 4 - Beta",
+ "Environment :: Console",
+ "Intended Audience :: Developers",
+ "Intended Audience :: System Administrators",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.1",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Topic :: Software Development :: Build Tools",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ ],
+)