summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index f3eb1a9..714fc88 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,15 +1,20 @@
#!/usr/bin/make -f
+# Get the supported Python versions
PYVERS := $(shell pyversions -r)
+# Get the supported Python3 versions
PY3VERS := $(shell py3versions -r)
%:
dh $@ --with python2,python3 --buildsystem=python_distutils
override_dh_auto_test:
+ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+ set -ex; \
for python in $(PYVERS) $(PY3VERS); do \
- $$python test.py; \
+ $$python test.py Basic ;\
done
+endif
override_dh_auto_build:
set -ex; \