summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorBen Carrillo <ben@futeisha.org>2013-02-05 23:00:53 +0900
committerBen Carrillo <ben@futeisha.org>2013-02-05 23:00:53 +0900
commit4c5f597132a0db4418b18b42385dde7f860afcb0 (patch)
tree2796b4bbd8d95552cd839235532bde82a461d8fe /debian/rules
initial commit1.07-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules37
1 files changed, 37 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..adb9a59
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,37 @@
+#!/usr/bin/make -f
+
+# This file was automatically generated by stdeb 0.6.0+git at
+# Mon, 28 Jan 2013 22:09:24 +0900
+
+PYVERS := $(shell pyversions -r)
+PY3VERS := $(shell py3versions -r)
+
+%:
+ dh $@ --with python2,python3 --buildsystem=python_distutils
+
+override_dh_auto_test:
+ for python in $(PYVERS) $(PY3VERS); do \
+ $$python test.py; \
+ done
+
+override_dh_auto_build:
+ set -ex; \
+ for python in $(PYVERS) $(PY3VERS); do \
+ $$python setup.py build; \
+ done
+
+override_dh_auto_install:
+ set -ex; \
+ for python in $(PYVERS); do \
+ $$python setup.py install --skip-build --root debian/python-sh \
+ --install-layout deb; \
+ done
+ set -ex; \
+ for python in $(PY3VERS); do \
+ $$python setup.py install --skip-build --root debian/python3-sh \
+ --install-layout deb; \
+ done
+
+override_dh_auto_clean:
+ rm -rf build
+ dh_auto_clean