summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/dont-search-for-libraries-in-usr-lib.patch16
-rw-r--r--debian/patches/fix-space-before-keywords.patch16
-rw-r--r--debian/patches/fix-spelling.patch25
-rw-r--r--debian/patches/series3
4 files changed, 60 insertions, 0 deletions
diff --git a/debian/patches/dont-search-for-libraries-in-usr-lib.patch b/debian/patches/dont-search-for-libraries-in-usr-lib.patch
new file mode 100644
index 0000000..47a22b8
--- /dev/null
+++ b/debian/patches/dont-search-for-libraries-in-usr-lib.patch
@@ -0,0 +1,16 @@
+Description: Don't search for libraries in /usr/lib.
+Author: Joel Rosdahl <joel@debian.org>
+
+Index: python-pysqlite1.1/setup.py
+===================================================================
+--- python-pysqlite1.1.orig/setup.py 2006-09-02 00:47:26.000000000 +0200
++++ python-pysqlite1.1/setup.py 2013-09-22 19:27:52.626779595 +0200
+@@ -12,7 +12,7 @@
+
+ if sys.platform in ("linux-i386", "linux2"): # most Linux
+ include_dirs = ['/usr/include/sqlite']
+- library_dirs = ['/usr/lib/']
++ library_dirs = []
+ libraries = [sqlite]
+ runtime_library_dirs = []
+ extra_objects = []
diff --git a/debian/patches/fix-space-before-keywords.patch b/debian/patches/fix-space-before-keywords.patch
new file mode 100644
index 0000000..0d44170
--- /dev/null
+++ b/debian/patches/fix-space-before-keywords.patch
@@ -0,0 +1,16 @@
+Description: Allow whitespace before keywords
+Author: Марк Коренберг <socketpair@gmail.com>
+
+Index: python-sqlite/sqlite/main.py
+===================================================================
+--- python-sqlite.orig/sqlite/main.py 2004-10-21 12:13:25.000000000 +0200
++++ python-sqlite/sqlite/main.py 2011-12-19 21:47:47.472609323 +0100
+@@ -233,7 +233,7 @@
+ if self.con.autocommit:
+ pass
+ else:
+- if not(self.con.inTransaction or SQL[:6].upper() in ("SELECT","VACUUM","DETACH")):
++ if not(self.con.inTransaction or SQL.lstrip()[:6].upper() in ("SELECT","VACUUM","DETACH")):
+ self.con._begin()
+ self.con.inTransaction = 1
+
diff --git a/debian/patches/fix-spelling.patch b/debian/patches/fix-spelling.patch
new file mode 100644
index 0000000..6bd9796
--- /dev/null
+++ b/debian/patches/fix-spelling.patch
@@ -0,0 +1,25 @@
+Description: Fix spelling.
+Author: Joel Rosdahl <joel@debian.org>
+
+Index: python-pysqlite1.1/_sqlite.c
+===================================================================
+--- python-pysqlite1.1.orig/_sqlite.c 2006-09-02 00:47:26.000000000 +0200
++++ python-pysqlite1.1/_sqlite.c 2011-06-29 21:58:20.473656828 +0200
+@@ -702,7 +702,7 @@
+
+ static char _con_set_command_logfile_doc[] =
+ "set_command_logfile(logfile)\n\
+-Registers a writeable file-like object as logfile where all SQL commands\n\
++Registers a writable file-like object as logfile where all SQL commands\n\
+ that get executed are written to.";
+
+ static PyObject* _con_set_command_logfile(pysqlc* self, PyObject *args, PyObject* kwargs)
+@@ -816,7 +816,7 @@
+ function.\n\
+ \n\
+ The signature of the callback function is (arg, values, colnames{, types}).\n\
+- types is ommitted unless use_types is true. If you use 'use_types', you\n\
++ types is omitted unless use_types is true. If you use 'use_types', you\n\
+ MUST have issued 'pragma show_datatypes=ON' before.";
+
+ static PyObject* _con_sqlite_exec(pysqlc* self, PyObject *args, PyObject* kwargs)
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..1978b14
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+fix-space-before-keywords.patch
+fix-spelling.patch
+dont-search-for-libraries-in-usr-lib.patch