summaryrefslogtreecommitdiff
path: root/debian/patches/noextraversion.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/noextraversion.patch')
-rw-r--r--debian/patches/noextraversion.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/debian/patches/noextraversion.patch b/debian/patches/noextraversion.patch
new file mode 100644
index 0000000..f88c476
--- /dev/null
+++ b/debian/patches/noextraversion.patch
@@ -0,0 +1,34 @@
+Index: pycryptopp/setup.py
+===================================================================
+--- pycryptopp.orig/setup.py 2013-08-22 16:56:10.818783603 -0400
++++ pycryptopp/setup.py 2013-08-22 16:56:44.165896373 -0400
+@@ -304,7 +304,7 @@
+ if mo:
+ return mo.group(1)
+
+-EXTRAVERSION_H_FNAME = os.path.join(EMBEDDED_CRYPTOPP_DIR, 'extraversion.h')
++#EXTRAVERSION_H_FNAME = os.path.join(EMBEDDED_CRYPTOPP_DIR, 'extraversion.h')
+
+ VERSION_BODY = '''
+ # This is the version of this tree, as created by %(versiontool)s from the
+@@ -335,13 +335,13 @@
+ # Let's avoid touching the change time (ctime) on the files unless
+ # they actually need to be updated.
+
+- if self.read_extraversion_h(EXTRAVERSION_H_FNAME) != version:
+- self.write_extraversion_h(
+- PKG,
+- version,
+- EXTRAVERSION_H_FNAME,
+- CPP_GIT_VERSION_BODY
+- )
++# if self.read_extraversion_h(EXTRAVERSION_H_FNAME) != version:
++# self.write_extraversion_h(
++# PKG,
++# version,
++# EXTRAVERSION_H_FNAME,
++# CPP_GIT_VERSION_BODY
++# )
+
+ if read_version_py(VERSION_PY_FNAME) != version:
+ self.write_version_py(