summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorbertagaz <bertagaz@ptitcanardnoir.org>2011-06-14 15:28:46 +0200
committerbertagaz <bertagaz@ptitcanardnoir.org>2011-06-14 15:28:46 +0200
commitc9ecdd0c5d99b8a55d5289a32669f310faa6477f (patch)
treeef7519972d56868d14c5b610b0a1a14cdb38046c /debian/patches
parent30e9097985656920f01a72efc1088caa2b8d41b3 (diff)
Import Debian patch.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/do_not_regenerate_darcs_stuff.patch31
-rw-r--r--debian/patches/move_testvectors_outside_site-packages.patch39
-rw-r--r--debian/patches/series2
3 files changed, 72 insertions, 0 deletions
diff --git a/debian/patches/do_not_regenerate_darcs_stuff.patch b/debian/patches/do_not_regenerate_darcs_stuff.patch
new file mode 100644
index 0000000..7472072
--- /dev/null
+++ b/debian/patches/do_not_regenerate_darcs_stuff.patch
@@ -0,0 +1,31 @@
+# upstream tarball already has all .py files generated by darcs / setuptools_darcs
+# no need to regenerate them
+Index: pycryptopp-0.5.29/setup.py
+===================================================================
+--- pycryptopp-0.5.29.orig/setup.py
++++ pycryptopp-0.5.29/setup.py
+@@ -226,7 +226,7 @@ install_requires = ['setuptools >= 0.6a9
+ # that are already in use), you may need to add it to setup.cfg and configure
+ # it to run darcsver before your command, if you want the version number to be
+ # correct when that command runs. http://pypi.python.org/pypi/darcsver
+-setup_requires.append('darcsver >= 1.6.3')
++#setup_requires.append('darcsver >= 1.6.3')
+
+ # setuptools_pyflakes is needed only if you want "./setup.py flakes" to run
+ # pyflakes on all the pycryptopp modules.
+Index: pycryptopp-0.5.29/setup.cfg
+===================================================================
+--- pycryptopp-0.5.29.orig/setup.cfg
++++ pycryptopp-0.5.29/setup.cfg
+@@ -10,8 +10,8 @@ tag_svn_revision = 0
+ sdist_dsc = darcsver --count-all-patches sdist_dsc
+ sdist = darcsver --count-all-patches sdist
+ trial = darcsver --count-all-patches trial
+-build = darcsver --count-all-patches build
+-install = darcsver --count-all-patches install
+-test = darcsver --count-all-patches test
++#build = darcsver --count-all-patches build
++#install = darcsver --count-all-patches install
++#test = darcsver --count-all-patches test
+ bdist_egg = darcsver --count-all-patches bdist_egg
+
diff --git a/debian/patches/move_testvectors_outside_site-packages.patch b/debian/patches/move_testvectors_outside_site-packages.patch
new file mode 100644
index 0000000..956370c
--- /dev/null
+++ b/debian/patches/move_testvectors_outside_site-packages.patch
@@ -0,0 +1,39 @@
+# moves testvecoros (i.e. non .py files) outside site-packages
+Index: pycryptopp-0.5.29/pycryptopp/test/__init__.py
+===================================================================
+--- /dev/null
++++ pycryptopp-0.5.29/pycryptopp/test/__init__.py
+@@ -0,0 +1,7 @@
++import os
++
++def resource_string(package_or_requirement, resource_name):
++ return file(os.path.join("/usr/share/python-pycryptopp/%s" % resource_name)).read()
++
++def resource_listdir(package_or_requirement, resource_name):
++ return os.listdir("/usr/share/python-pycryptopp/%s" % resource_name)
+Index: pycryptopp-0.5.29/pycryptopp/test/test_aes.py
+===================================================================
+--- pycryptopp-0.5.29.orig/pycryptopp/test/test_aes.py
++++ pycryptopp-0.5.29/pycryptopp/test/test_aes.py
+@@ -11,7 +11,7 @@ VERBOSE=False
+
+ from pycryptopp.cipher import aes
+
+-from pkg_resources import resource_string, resource_listdir
++from pycryptopp.test import resource_string, resource_listdir
+
+ from base64 import b32encode
+ def ab(x): # debuggery
+Index: pycryptopp-0.5.29/pycryptopp/test/test_sha256.py
+===================================================================
+--- pycryptopp-0.5.29.orig/pycryptopp/test/test_sha256.py
++++ pycryptopp-0.5.29/pycryptopp/test/test_sha256.py
+@@ -11,7 +11,7 @@ VERBOSE=False
+
+ from pycryptopp.hash import sha256
+
+-from pkg_resources import resource_string
++from pycryptopp.test import resource_string
+
+ def resource_string_lines(pkgname, resname):
+ return split_on_newlines(resource_string(pkgname, resname))
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..721518e
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+move_testvectors_outside_site-packages.patch
+do_not_regenerate_darcs_stuff.patch