summaryrefslogtreecommitdiff
path: root/jsonschema-0.6/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'jsonschema-0.6/setup.py')
-rw-r--r--jsonschema-0.6/setup.py38
1 files changed, 38 insertions, 0 deletions
diff --git a/jsonschema-0.6/setup.py b/jsonschema-0.6/setup.py
new file mode 100644
index 0000000..7b69ae8
--- /dev/null
+++ b/jsonschema-0.6/setup.py
@@ -0,0 +1,38 @@
+from distutils.core import setup
+
+from jsonschema import __version__
+
+
+with open("README.rst") as readme:
+ long_description = readme.read()
+
+
+classifiers = [
+ "Development Status :: 3 - Alpha",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.1",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+]
+
+
+setup(
+ name="jsonschema",
+ version=__version__,
+ py_modules=["jsonschema"],
+ author="Julian Berman",
+ author_email="Julian@GrayVines.com",
+ classifiers=classifiers,
+ description="An implementation of JSON-Schema validation for Python",
+ license="MIT/X",
+ long_description=long_description,
+ url="http://github.com/Julian/jsonschema",
+)