summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index b8b2e60..41f7383 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,11 +12,14 @@ package3=python3-gnupg-ng
export PYBUILD_DESTDIR_python2=debian/$(package)/
export PYBUILD_DESTDIR_python3=debian/$(package3)/
+WITH_SPHINXDOC = $(shell if [ -x /usr/bin/dh_sphinxdoc ]; then echo "--with sphinxdoc"; fi)
+
PYVERS=$(shell pyversions -r)
PY3VERS = $(shell py3versions -r)
%:
- dh $@ --with python2,python3,sphinxdoc --buildsystem=python_distutils
+ dh $@ --with python2,python3 $(WITH_SPHINXDOC) --buildsystem=python_distutils
+
override_dh_compress:
dh_compress -i -X.rst -X.js -X.html -X.txt
@@ -30,7 +33,8 @@ override_dh_auto_build:
override_dh_auto_clean:
dh_auto_clean
- rm -rf build debian/docs docs/_build *.egg-info __pycache__
+ rm -rf build *.egg-info __pycache__
+ # docs/_build debian/docs
find \( -name '._*' -o -name '*.pyc' \) -delete
override_dh_auto_install: