summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..dc97b46
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+# Uncomment this to turn on verbose mode.
+#DH_VERBOSE=1
+
+%:
+ dh $@ --with python2 --buildsystem=python_distutils
+
+build-python%:
+ python$* setup.py build_sqlcipher
+
+install-python%:
+ python$* setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb
+
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -rf build
+ rm -rf docs/_build
+ rm -rf *.egg-info