summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 6d7b1af..db8924e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,12 +5,12 @@
%:
dh $@ --with python2 --buildsystem=python_distutils
-build-python%:
+override_dh_auto_build:
python$* setup.py build_sqlcipher
-install-python%:
- python$* setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb
-
+override_dh_auto_install:
+ python$* setup.py install --skip-build --root=debian/python-sqlcipher \
+ --install-layout=deb
override_dh_auto_clean:
dh_auto_clean