summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2013-05-30 04:57:06 +0900
committerKali Kaneko <kali@leap.se>2013-05-31 03:19:39 +0900
commit4623e6a111193e46a5b86319d3a505f814f024f2 (patch)
treecf9077122bb9cce40e4d7a0f3eb3fec979705aed /setup.py
parent0ebb159495b941dc40c1f9eaeab250e87edaea7b (diff)
initial debian files
* do not use amalgamation builder * add include dir for libsqlcipher * add libsqlcipher-dev as build-dep
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index dff0c64..ac1a3cd 100644
--- a/setup.py
+++ b/setup.py
@@ -48,7 +48,7 @@ sqlite = "sqlite"
PYSQLITE_EXPERIMENTAL = False
#DEV_VERSION = None
-DEV_VERSION = "1"
+DEV_VERSION = "02"
sources = ["src/module.c", "src/connection.c", "src/cursor.c", "src/cache.c",
"src/microprotocols.c", "src/prepare_protocol.c", "src/statement.c",
@@ -146,6 +146,7 @@ class LibSQLCipherBuilder(build_ext):
description = ("Build C extension linking against libsqlcipher library.")
def build_extension(self, ext):
+ ext.extra_compile_args.append("-I/usr/include/sqlcipher/")
ext.extra_link_args.append("-lsqlcipher")
build_ext.build_extension(self, ext)